{"answers":{"affected":"5 open source packages ship an affected version, including compliance-trestle.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-46380 exists.","fix":"Upgrade compliance-trestle to a fixed version for your release line: 3.12.2 or 4.0.3.","what":"CVE-2026-46380 is a medium-severity server-side request forgery vulnerability in oscal-compass compliance-trestle, published on 14 Aug 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-46380 and fix it if it is affected.\n\nWhat it is: CVE-2026-46380 is a medium-severity server-side request forgery vulnerability in oscal-compass compliance-trestle, published on 14 Aug 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-46380 exists.\n\nAffected packages and fixed versions:\n- compliance-trestle (PyPI): affected all versions; fixed in 3.12.2, 4.0.3\n- compliance-trestle (PyPI): affected all versions; fixed in 3.12.2\n- compliance-trestle (PyPI): affected all versions; fixed in 3.12.2\n- compliance-trestle (PyPI): affected from 4.0.0; fixed in 4.0.3\n- compliance-trestle (PyPI): affected from 4.0.0; fixed in 4.0.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-46380/ (Markdown: https://insights.sbomify.com/CVE-2026-46380/index.md)","id":"CVE-2026-46380","markdown":"https://insights.sbomify.com/CVE-2026-46380/index.md","name":"CVE-2026-46380","record":{"aliases":["GHSA-w76h-q7c6-jpjp","PYSEC-2026-2427"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Compliance as code tool","requires_auth":"low_privilege","summary":"An attacker can exploit Server-Side Request Forgery in compliance-trestle to access internal services or cloud metadata endpoints.","user_interaction":"required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":6.7,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:C/C:H/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"}],"description":"compliance-trestle is a tooling platform for managing compliance as code. Prior to versions 3.12.2 and 4.0.3, the HTTPSFetcher._do_fetch() method passes a user-supplied URL directly to requests.get() without validation. This allows an attacker to perform Server-Side Request Forgery, targeting internal services or cloud metadata endpoints. Versions 3.12.2 and 4.0.3 fix the issue.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"compliance-trestle Vulnerable to SSRF in Remote Fetching Subsystem","id":"CVE-2026-46380","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"ssrf","year":"2026"},"n_packages":5,"n_references":4,"next":{"headline":"Meeting Room Booking System has server-side request forgery in import functionality","id":"CVE-2026-46382"},"packages":[{"ecosystem":"PyPI","fixed":["3.12.2","4.0.3"],"introduced":["0","4.0.0"],"last_affected":[],"package":"compliance-trestle","purl":"pkg:pypi/compliance-trestle","source":"PYSEC-2026-2427"},{"ecosystem":"PyPI","fixed":["3.12.2"],"introduced":["0"],"last_affected":[],"package":"compliance-trestle","purl":null,"source":"GHSA-w76h-q7c6-jpjp"},{"ecosystem":"PyPI","fixed":["3.12.2"],"introduced":["0"],"last_affected":[],"package":"compliance-trestle","purl":"pkg:pypi/compliance-trestle","source":"GHSA-w76h-q7c6-jpjp"},{"ecosystem":"PyPI","fixed":["4.0.3"],"introduced":["4.0.0"],"last_affected":[],"package":"compliance-trestle","purl":null,"source":"GHSA-w76h-q7c6-jpjp"},{"ecosystem":"PyPI","fixed":["4.0.3"],"introduced":["4.0.0"],"last_affected":[],"package":"compliance-trestle","purl":"pkg:pypi/compliance-trestle","source":"GHSA-w76h-q7c6-jpjp"}],"prev":{"headline":"Dasel: Denial of service in dasel selector lexer due to infinite loop on unterminated regex literal","id":"CVE-2026-46378"},"products":["compliance-trestle"],"published":"2026-08-14","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-08-17","vendors":["oscal-compass"]},"summary":"An attacker can exploit Server-Side Request Forgery in compliance-trestle to access internal services or cloud metadata endpoints.","url":"https://insights.sbomify.com/CVE-2026-46380/"}