{"answers":{"affected":"3 open source packages ship an affected version, including apm-cli.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-46383 exists.","fix":"Upgrade apm-cli to 0.13.0 or later.","what":"CVE-2026-46383 is a medium-severity path traversal vulnerability in microsoft apm, published on 15 May 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-46383 and fix it if it is affected.\n\nWhat it is: CVE-2026-46383 is a medium-severity path traversal vulnerability in microsoft apm, published on 15 May 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-46383 exists.\n\nAffected packages and fixed versions:\n- apm-cli (PyPI): affected all versions; fixed in 0.13.0\n- apm-cli (PyPI): affected all versions; fixed in 0.13.0\n- apm-cli (PyPI): affected all versions; fixed in 0.13.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-46383/ (Markdown: https://insights.sbomify.com/CVE-2026-46383/index.md)","id":"CVE-2026-46383","markdown":"https://insights.sbomify.com/CVE-2026-46383/index.md","name":"CVE-2026-46383","record":{"aliases":["GHSA-mq5j-pw29-jcv3","PYSEC-2026-2378"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution","data_modify"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Microsoft APM","requires_auth":"none","summary":"Attackers can overwrite arbitrary files on Windows systems via malicious tar archives during apm install, potentially leading to code execution.","user_interaction":"required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":5.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-73","name":"External Control of File Name or Path"},{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"Microsoft APM is an open-source, community-driven dependency manager for AI agents. Prior to 0.13.0, Microsoft APM contains a Windows-specific archive extraction boundary failure in the legacy-bundle probe used by apm install \u003cbundle\u003e on supported Python 3.10 and 3.11 runtimes. When apm install is given a local .tar.gz that is not recognized as a plugin-format bundle, APM probes whether it is a legacy --format apm bundle. On Python versions earlier than 3.12, that probe extracts untrusted tar members with raw tar.extractall() without rejecting Windows absolute member names such as D:/.... This vulnerability is fixed in 0.13.0.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Microsoft APM: Windows absolute-path tar member overwrite during legacy-bundle probing in `apm install`","id":"CVE-2026-46383","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"path_traversal","year":"2026"},"n_packages":3,"n_references":1,"next":{"headline":"iskorotkov/avro: Integer Overflow in Avro Decoder","id":"CVE-2026-46384"},"packages":[{"ecosystem":"PyPI","fixed":["0.13.0"],"introduced":["0"],"last_affected":[],"package":"apm-cli","purl":null,"source":"GHSA-mq5j-pw29-jcv3"},{"ecosystem":"PyPI","fixed":["0.13.0"],"introduced":["0"],"last_affected":[],"package":"apm-cli","purl":"pkg:pypi/apm-cli","source":"GHSA-mq5j-pw29-jcv3"},{"ecosystem":"PyPI","fixed":["0.13.0"],"introduced":["0"],"last_affected":[],"package":"apm-cli","purl":"pkg:pypi/apm-cli","source":"PYSEC-2026-2378"}],"prev":{"headline":"Meeting Room Booking System has server-side request forgery in import functionality","id":"CVE-2026-46382"},"products":["apm"],"published":"2026-05-15","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-05-15","vendors":["microsoft"]},"summary":"Attackers can overwrite arbitrary files on Windows systems via malicious tar archives during apm install, potentially leading to code execution.","url":"https://insights.sbomify.com/CVE-2026-46383/"}