# CVE-2026-46391: HAX open-apis: Credential Theft via Server-Side Request Forgery (SSRF) in open-apis

> An attacker can exploit SSRF in HAX CMS open-apis to steal authentication credentials by bypassing hostname validation checks.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:L/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Jun 2026
- **Updated:** 8 Jun 2026
- **Also known as:** GHSA-4fg7-f244-3j49

## What is CVE-2026-46391?

CVE-2026-46391 is a high-severity server-side request forgery vulnerability in @haxtheweb/open-apis, published on 5 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

HAX CMS helps manage microsite universe with PHP or NodeJs backends. Starting in version 9.0.1 and prior to version 26.0.0 of @haxtheweb/open-apis, multiple functions conduct substring-only matching to validate hostnames to which basic authorization should be sent. An attacker can append the matched substrings to an attacker-controlled endpoint and capture authentication. Version 26.0.0 fixes the issue.

Weakness: CWE-918 (Server-Side Request Forgery), CWE-183 (Permissive List of Allowed Inputs)

## Which versions are affected by CVE-2026-46391?

2 open source packages ship an affected version, including @haxtheweb/open-apis.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@haxtheweb/open-apis` | npm | All versions | 26.0.0 |
| `@haxtheweb/open-apis` | npm | All versions | 26.0.0 |

## How do I fix CVE-2026-46391?

Upgrade @haxtheweb/open-apis to 26.0.0 or later.

## Is CVE-2026-46391 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-46391 exists.

Public exploit code:

- Proof of concept exploit for CVE-2026-46391 (github_poc): https://github.com/bradyjmcl/cve-2026-46391

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-46391 and fix it if it is affected.

What it is: CVE-2026-46391 is a high-severity server-side request forgery vulnerability in @haxtheweb/open-apis, published on 5 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-46391 exists.

Affected packages and fixed versions:
- @haxtheweb/open-apis (npm): affected all versions; fixed in 26.0.0
- @haxtheweb/open-apis (npm): affected all versions; fixed in 26.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-46391/ (Markdown: https://insights.sbomify.com/CVE-2026-46391/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-46391
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-46391
- OSV: https://osv.dev/vulnerability/CVE-2026-46391

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-46391/
Summaries are generated and may contain mistakes; the official description above is the record.
