# CVE-2026-46406: Claude Code: Insecure Temporary File in /copy Command Enables Response Disclosure and Symlink-Based File Write

> Local attackers can read privileged user responses or overwrite arbitrary files via symlink attacks due to insecure temporary file handling in the /copy command.

- **Severity:** Medium 4.4 (`CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:A/VC:L/VI:L/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 29 Jun 2026
- **Updated:** 29 Jun 2026
- **Also known as:** GHSA-4vp2-6q8c-pvq2, MINI-7jrw-xrv3-pcw9, MINI-ch3q-w3rc-2w9r

## What is CVE-2026-46406?

CVE-2026-46406 is a medium-severity path traversal vulnerability in anthropics claude-code, published on 29 Jun 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Claude Code is an agentic coding tool.  From 2.1.59 until 2.1.128, the Claude Code /copy command wrote responses to a hardcoded, predictable path (/tmp/claude/response.md) without UID isolation, randomness, or symlink protection. The file was created world-readable (0644) in a world-traversable directory (0755), allowing any local user to read a privileged user's Claude response, which could contain secrets or credentials. Additionally, because the path was static and predictable, a local attacker could pre-create the directory and plant a symlink at the expected file path, causing the privileged process to follow the symlink and overwrite an attacker-chosen file with the response text. Exploiting this required a local unprivileged user on the same system and a privileged user to run the /copy command. This vulnerability is fixed in 2.1.128.

Weakness: CWE-59 (Improper Link Resolution Before File Access), CWE-377 (DEPRECATED: Insecure Temporary File), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-46406?

2 open source packages ship an affected version, including @anthropic-ai/claude-code. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@anthropic-ai/claude-code` | npm | From 2.1.59 | 2.1.128 |
| `@anthropic-ai/claude-code` | npm | From 2.1.59 | 2.1.128 |

Products: Anthropic Claude Code.

## How do I fix CVE-2026-46406?

Upgrade @anthropic-ai/claude-code to 2.1.128 or later.

## Is CVE-2026-46406 being exploited?

There is no known exploitation of CVE-2026-46406 in the wild and no public exploit code.

## Other vulnerabilities in anthropics claude-code

- [CVE-2025-66032](https://insights.sbomify.com/CVE-2025-66032/): Claude Code Command Validation Bypass Allows Arbitrary Code Execution (high 8.7)
- [CVE-2025-64755](https://insights.sbomify.com/CVE-2025-64755/): @anthropic-ai/claude-code has Sed Command Validation Bypass that Allows Arbitrary File Writes (high 8.7)
- [CVE-2025-59536](https://insights.sbomify.com/CVE-2025-59536/): Claude Code's startup trust dialog could lead to Command Execution attack (high 8.7)
- [CVE-2025-58764](https://insights.sbomify.com/CVE-2025-58764/): Claude Code rg command had Command Injection that allowed bypass of user approval prompt for command execution (high 8.7)
- [CVE-2025-59041](https://insights.sbomify.com/CVE-2025-59041/): Claude Code vulnerable to arbitrary code execution caused by maliciously configured git email (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-46406 and fix it if it is affected.

What it is: CVE-2026-46406 is a medium-severity path traversal vulnerability in anthropics claude-code, published on 29 Jun 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-46406 in the wild and no public exploit code.

Affected packages and fixed versions:
- @anthropic-ai/claude-code (npm): affected from 2.1.59; fixed in 2.1.128
- @anthropic-ai/claude-code (npm): affected from 2.1.59; fixed in 2.1.128

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-46406/ (Markdown: https://insights.sbomify.com/CVE-2026-46406/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-46406
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-46406
- OSV: https://osv.dev/vulnerability/CVE-2026-46406

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-46406/
Summaries are generated and may contain mistakes; the official description above is the record.
