CVE-2026-46411 FlashMQ: Client can trigger uncaught exception on FlashMQ 1.26.1 and older

Medium 6.5 Published Updated

Authorized clients can crash the FlashMQ MQTT broker by exceeding write buffer limits, causing a server abort.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2026-46411?

CVE-2026-46411 is a medium-severity denial of service vulnerability in halfgaar FlashMQ, published on 9 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

FlashMQ is a MQTT broker/server, designed for multi-CPU environments. Prior to version 1.26.2, authorized clients have the ability to exceed the permitted over-commit of their write buffer and triggering an internal safe-guard exception. This exception was in a path that was not catchable, and therefore causes a server abort. This issue has been patched in version 1.26.2.

Weakness: CWE-248

Which versions are affected by CVE-2026-46411?

How do I fix CVE-2026-46411?

No fix has been published for CVE-2026-46411 yet. Limit exposure of the affected software until one is available.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-46411 being exploited?

There is no known exploitation of CVE-2026-46411 in the wild and no public exploit code.

Sources

Also known as GHSA-g35r-265r-rxrh.

Is CVE-2026-46411 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free