# CVE-2026-46411: FlashMQ: Client can trigger uncaught exception on FlashMQ 1.26.1 and older

> Authorized clients can crash the FlashMQ MQTT broker by exceeding write buffer limits, causing a server abort.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 9 Jun 2026
- **Updated:** 10 Jun 2026
- **Also known as:** GHSA-g35r-265r-rxrh

## What is CVE-2026-46411?

CVE-2026-46411 is a medium-severity denial of service vulnerability in halfgaar FlashMQ, published on 9 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

FlashMQ is a MQTT broker/server, designed for multi-CPU environments. Prior to version 1.26.2, authorized clients have the ability to exceed the permitted over-commit of their write buffer and triggering an internal safe-guard exception. This exception was in a path that was not catchable, and therefore causes a server abort. This issue has been patched in version 1.26.2.

Weakness: CWE-248 (Uncaught Exception)

## Which versions are affected by CVE-2026-46411?


## How do I fix CVE-2026-46411?

No fix has been published for CVE-2026-46411 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-46411 being exploited?

There is no known exploitation of CVE-2026-46411 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-46411 and fix it if it is affected.

What it is: CVE-2026-46411 is a medium-severity denial of service vulnerability in halfgaar FlashMQ, published on 9 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-46411 in the wild and no public exploit code.

Affected product: halfgaar FlashMQ. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-46411/ (Markdown: https://insights.sbomify.com/CVE-2026-46411/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-46411
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-46411
- OSV: https://osv.dev/vulnerability/CVE-2026-46411

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-46411/
Summaries are generated and may contain mistakes; the official description above is the record.
