# CVE-2026-46415: Caddy Defender trusted proxy client IP bypass

> Attackers can bypass IP blocking rules in Caddy Defender when Caddy is behind a trusted proxy by exploiting incorrect client IP resolution.

- **Severity:** High 8.2 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Jul 2026
- **Updated:** 21 Jul 2026
- **Also known as:** GHSA-3h23-rrpc-3p87, GO-2026-5086

## What is CVE-2026-46415?

CVE-2026-46415 is a high-severity vulnerability in JasonLovesDoggo caddy-defender, published on 20 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Caddy Defender plugin is a middleware for Caddy that allows users to block or manipulate requests based on the client's IP address. Prior to version 0.10.1, Caddy Defender used `r.RemoteAddr` when evaluating whether a request should be blocked. `RemoteAddr` is the address of the immediate peer connected to Caddy. In deployments where Caddy is behind a trusted proxy, CDN, or load balancer, the immediate peer is usually the proxy, not the original client. Caddy resolves the original client address into its `client_ip` request variable after applying the configured `trusted_proxies` policy, but Defender did not use that value. As a result, clients from blocked IP ranges could bypass Defender when accessing Caddy through a trusted proxy whose own IP address was not blocked. This affects deployments that use Defender behind trusted proxies and expect it to enforce blocking based on the real client IP. The issue is fixed in version 0.10.1 by making Defender prefer Caddys resolved `client_ip` request variable when it is available. Defender falls back to `RemoteAddr` only when Caddy has not provided a resolved client IP. There is no complete workaround in affected Defender versions for deployments that rely on Caddy's trusted proxy client IP resolution. Until upgrading, affected users should enforce equivalent IP blocking at the trusted proxy, CDN, load balancer, firewall, or other edge layer before traffic reaches Caddy. Deployments where Caddy receives traffic directly from clients, without an intermediate trusted proxy, are not affected by this bypass.

Weakness: CWE-348 (Use of Less Trusted Source), CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2026-46415?

3 open source packages ship an affected version, including pkg.jsn.cam/caddy-defender.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pkg.jsn.cam/caddy-defender` | Go | All versions | 0.10.1 |
| `pkg.jsn.cam/caddy-defender` | Go | All versions | 0.10.1 |
| `pkg.jsn.cam/caddy-defender` | Go | All versions | 0.10.1 |

## How do I fix CVE-2026-46415?

Upgrade pkg.jsn.cam/caddy-defender to 0.10.1 or later.

## Is CVE-2026-46415 being exploited?

There is no known exploitation of CVE-2026-46415 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-46415 and fix it if it is affected.

What it is: CVE-2026-46415 is a high-severity vulnerability in JasonLovesDoggo caddy-defender, published on 20 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-46415 in the wild and no public exploit code.

Affected packages and fixed versions:
- pkg.jsn.cam/caddy-defender (Go): affected all versions; fixed in 0.10.1
- pkg.jsn.cam/caddy-defender (Go): affected all versions; fixed in 0.10.1
- pkg.jsn.cam/caddy-defender (Go): affected all versions; fixed in 0.10.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-46415/ (Markdown: https://insights.sbomify.com/CVE-2026-46415/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-46415
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-46415
- OSV: https://osv.dev/vulnerability/CVE-2026-46415

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-46415/
Summaries are generated and may contain mistakes; the official description above is the record.
