CVE-2026-46421 Supply chain compromise via malicious package versions (@cap-js/sqlite, @cap-js/postgres, @cap-js/db-service)

Critical 9.3 Published Updated

Malicious npm packages harvested credentials and self-propagated, requiring immediate upgrades and credential rotation for affected SAP CAP JS users.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-46421?

CVE-2026-46421 is a critical vulnerability in @cap-js/db-service, published on 15 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

The SAP Cloud Application Programming Model is a tool for building enterprise-grade cloud applications, and cap-js/cds-dbs is the monorepo for SQL database services for that tool. On April 29, 2026, compromised versions of `@cap-js/[email protected]`, `@cap-js/[email protected]`, and `@cap-js/[email protected]` were published. The malicious packages harvested credentials and attempted self-propagation. If a compromised version was installed, all credentials accessible on that machine (npm tokens, cloud provider credentials, SSH keys, GitHub PATs) should be considered compromised. User should upgrade to `@cap-js/sqlite` >= 2.4.0, `@cap-js/postgres` >= 2.3.0, `@cap-js/db-service` >= 2.11.0. If a compromised version was ever installed, rotate all affected credentials. No known workarounds are available.

Weakness: CWE-506

Which versions are affected by CVE-2026-46421?

6 open source packages ship an affected version, including @cap-js/db-service, @cap-js/postgres and @cap-js/sqlite.

PackageAffectedFixed in
@cap-js/db-service npmFrom 2.10.12.11.0
@cap-js/db-service npmFrom 2.10.12.11.0
@cap-js/postgres npmFrom 2.2.22.3.0
@cap-js/postgres npmFrom 2.2.22.3.0
@cap-js/sqlite npmFrom 2.2.22.3.0
@cap-js/sqlite npmFrom 2.2.22.3.0

How do I fix CVE-2026-46421?

Upgrade @cap-js/db-service to 2.11.0 or later.

Is CVE-2026-46421 being exploited?

There is no known exploitation of CVE-2026-46421 in the wild and no public exploit code.

Sources

Also known as GHSA-pvw4-cvr4-97p8.

Is CVE-2026-46421 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free