{"answers":{"affected":"6 open source packages ship an affected version, including @cap-js/db-service, @cap-js/postgres and @cap-js/sqlite.","exploited":"There is no known exploitation of CVE-2026-46421 in the wild and no public exploit code.","fix":"Upgrade @cap-js/db-service to 2.11.0 or later.","what":"CVE-2026-46421 is a critical vulnerability in @cap-js/db-service, published on 15 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-46421 and fix it if it is affected.\n\nWhat it is: CVE-2026-46421 is a critical vulnerability in @cap-js/db-service, published on 15 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-46421 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @cap-js/db-service (npm): affected from 2.10.1; fixed in 2.11.0\n- @cap-js/db-service (npm): affected from 2.10.1; fixed in 2.11.0\n- @cap-js/postgres (npm): affected from 2.2.2; fixed in 2.3.0\n- @cap-js/postgres (npm): affected from 2.2.2; fixed in 2.3.0\n- @cap-js/sqlite (npm): affected from 2.2.2; fixed in 2.3.0\n- @cap-js/sqlite (npm): affected from 2.2.2; fixed in 2.3.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-46421/ (Markdown: https://insights.sbomify.com/CVE-2026-46421/index.md)","id":"CVE-2026-46421","markdown":"https://insights.sbomify.com/CVE-2026-46421/index.md","name":"CVE-2026-46421","record":{"aliases":["GHSA-pvw4-cvr4-97p8"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"SAP CAP JS database libraries","requires_auth":"none","summary":"Malicious npm packages harvested credentials and self-propagated, requiring immediate upgrades and credential rotation for affected SAP CAP JS users.","user_interaction":"not_required","vuln_class":"supply_chain"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":9.3,"severity":"critical","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-506","name":"Embedded Malicious Code"}],"description":"The SAP Cloud Application Programming Model is a tool for building enterprise-grade cloud applications, and cap-js/cds-dbs is the monorepo for SQL database services for that tool. On April 29, 2026, compromised versions of `@cap-js/sqlite@2.2.2`, `@cap-js/postgres@2.2.2`, and `@cap-js/db-service@2.10.1` were published. The malicious packages harvested credentials and attempted self-propagation. If a compromised version was installed, all credentials accessible on that machine (npm tokens, cloud provider credentials, SSH keys, GitHub PATs) should be considered compromised. User should upgrade to `@cap-js/sqlite` \u003e= 2.4.0, `@cap-js/postgres` \u003e= 2.3.0, `@cap-js/db-service` \u003e= 2.11.0. If a compromised version was ever installed, rotate all affected credentials. No known workarounds are available.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Supply chain compromise via malicious package versions (@cap-js/sqlite, @cap-js/postgres, @cap-js/db-service)","id":"CVE-2026-46421","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"supply_chain","year":"2026"},"n_packages":6,"n_references":4,"next":{"headline":"Rocket.Chat: SAML signature validation skipped when IdP certificate field is empty","id":"CVE-2026-46423"},"packages":[{"ecosystem":"npm","fixed":["2.11.0"],"introduced":["2.10.1"],"last_affected":[],"package":"@cap-js/db-service","purl":null,"source":"GHSA-pvw4-cvr4-97p8"},{"ecosystem":"npm","fixed":["2.11.0"],"introduced":["2.10.1"],"last_affected":[],"package":"@cap-js/db-service","purl":"pkg:npm/%40cap-js/db-service","source":"GHSA-pvw4-cvr4-97p8"},{"ecosystem":"npm","fixed":["2.3.0"],"introduced":["2.2.2"],"last_affected":[],"package":"@cap-js/postgres","purl":null,"source":"GHSA-pvw4-cvr4-97p8"},{"ecosystem":"npm","fixed":["2.3.0"],"introduced":["2.2.2"],"last_affected":[],"package":"@cap-js/postgres","purl":"pkg:npm/%40cap-js/postgres","source":"GHSA-pvw4-cvr4-97p8"},{"ecosystem":"npm","fixed":["2.3.0"],"introduced":["2.2.2"],"last_affected":[],"package":"@cap-js/sqlite","purl":null,"source":"GHSA-pvw4-cvr4-97p8"},{"ecosystem":"npm","fixed":["2.3.0"],"introduced":["2.2.2"],"last_affected":[],"package":"@cap-js/sqlite","purl":"pkg:npm/%40cap-js/sqlite","source":"GHSA-pvw4-cvr4-97p8"}],"prev":{"headline":"setup-php: Command Injection in Repository-Derived PHP Version Resolution","id":"CVE-2026-46420"},"products":["@cap-js/db-service","@cap-js/postgres","@cap-js/sqlite"],"published":"2026-07-15","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-07-15","vendors":["@cap-js/db-service","cap-js"]},"summary":"Malicious npm packages harvested credentials and self-propagated, requiring immediate upgrades and credential rotation for affected SAP CAP JS users.","url":"https://insights.sbomify.com/CVE-2026-46421/"}