# CVE-2026-46425: Budibase: SCIM endpoints lack role-based authorization, BASIC users CRUD tenant users

> Authenticated users with basic roles can create, read, update, or delete any tenant user and group via SCIM endpoints due to missing role checks.

- **Severity:** Critical 9.9 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 27 May 2026
- **Updated:** 28 May 2026
- **Also known as:** GHSA-q9rw-q89f-jx2f

## What is CVE-2026-46425?

CVE-2026-46425 is a critical missing authorization vulnerability in budibase, published on 27 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Budibase is an open-source low-code platform. Prior to 3.38.2, packages/worker/src/api/routes/global/scim.ts attaches only two middlewares to the SCIM router: requireSCIM (checks the Enterprise feature flag and SCIM config) and doInScimContext (sets the SCIM request context). There is no role check. Any authenticated user who reaches the worker (BASIC role, workspace-scoped builder, anyone) can call SCIM endpoints and CRUD every user and group in the tenant. This vulnerability is fixed in 3.38.2.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-46425?


## How do I fix CVE-2026-46425?

No fix has been published for CVE-2026-46425 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-46425 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-46425 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-46425 and fix it if it is affected.

What it is: CVE-2026-46425 is a critical missing authorization vulnerability in budibase, published on 27 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-46425 exists.

Affected product: budibase. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-46425/ (Markdown: https://insights.sbomify.com/CVE-2026-46425/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-46425
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-46425
- OSV: https://osv.dev/vulnerability/CVE-2026-46425

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-46425/
Summaries are generated and may contain mistakes; the official description above is the record.
