# CVE-2026-46426: Budibase: Unrestricted Upload of File with Dangerous Type

> Authenticated builders can upload malicious scripts via file uploads, leading to persistent stored XSS affecting all application end users.

- **Severity:** High 7.6 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 27 May 2026
- **Updated:** 27 May 2026
- **Also known as:** GHSA-82rc-gxrg-v4gf

## What is CVE-2026-46426?

CVE-2026-46426 is a high-severity cross-site scripting vulnerability in budibase, published on 27 May 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Budibase is an open-source low-code platform. Prior to 3.38.2, the file upload endpoint POST /api/attachments/process does not enforce active-content restrictions for authenticated users. The checks for dangerous file extensions are conditionally wrapped inside if (isPublicUser) or if (isPublicUser || !env.SELF_HOSTED), meaning any authenticated builder can upload executable web content — SVG files with inline <script> tags, HTML pages with JavaScript, .js modules — which are then stored in the object store (MinIO/S3) with their correct MIME types. When the resulting signed URL is opened by any app user, the browser executes the payload. Impact is persistent stored XSS over all application end users. This vulnerability is fixed in 3.38.2.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-434 (Unrestricted Upload of File with Dangerous Type)

## Which versions are affected by CVE-2026-46426?

2 open source packages ship an affected version, including budibase.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `budibase` | npm | All versions | 3.38.2 |
| `budibase` | npm | All versions | 3.38.2 |

## How do I fix CVE-2026-46426?

Upgrade budibase to 3.38.2 or later.

## Is CVE-2026-46426 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-46426 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-46426 and fix it if it is affected.

What it is: CVE-2026-46426 is a high-severity cross-site scripting vulnerability in budibase, published on 27 May 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-46426 exists.

Affected packages and fixed versions:
- budibase (npm): affected all versions; fixed in 3.38.2
- budibase (npm): affected all versions; fixed in 3.38.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-46426/ (Markdown: https://insights.sbomify.com/CVE-2026-46426/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-46426
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-46426
- OSV: https://osv.dev/vulnerability/CVE-2026-46426

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-46426/
Summaries are generated and may contain mistakes; the official description above is the record.
