# CVE-2026-46432: LMDeploy: Arbitrary code execution via hardcoded trust_remote_code=True in lmdeploy model initialization

> Attackers can execute arbitrary code by exploiting hardcoded trust_remote_code settings in LMDeploy's model initialization process.

- **Severity:** High 7.8 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Jun 2026
- **Updated:** 11 Jun 2026
- **Also known as:** GHSA-m549-qq94-fvhg, PYSEC-2026-2609

## What is CVE-2026-46432?

CVE-2026-46432 is a high-severity code injection vulnerability in InternLM lmdeploy, published on 9 Jun 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

LMDeploy is a toolkit for compressing, deploying, and serving large language models. In versions 0.12.3 and prior, LMDeploy is vulnerable to arbitrary code execution through hardcoded "trust_remote_code=True" in multiple HuggingFace model-loading call sites. At time of publication, there are no publicly available patches.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2026-46432?

3 open source packages ship an affected version, including lmdeploy.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `lmdeploy` | PyPI | All versions | 0.13.0 |
| `lmdeploy` | PyPI | All versions | 0.13.0 |
| `lmdeploy` | PyPI | All versions | 0.13.0 |

## How do I fix CVE-2026-46432?

Upgrade lmdeploy to 0.13.0 or later.

## Is CVE-2026-46432 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-46432 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-46432 and fix it if it is affected.

What it is: CVE-2026-46432 is a high-severity code injection vulnerability in InternLM lmdeploy, published on 9 Jun 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-46432 exists.

Affected packages and fixed versions:
- lmdeploy (PyPI): affected all versions; fixed in 0.13.0
- lmdeploy (PyPI): affected all versions; fixed in 0.13.0
- lmdeploy (PyPI): affected all versions; fixed in 0.13.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-46432/ (Markdown: https://insights.sbomify.com/CVE-2026-46432/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-46432
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-46432
- OSV: https://osv.dev/vulnerability/CVE-2026-46432

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-46432/
Summaries are generated and may contain mistakes; the official description above is the record.
