CVE-2026-46433 lldpd: Heap OOB Read in VLAN Decapsulation memmove
A heap buffer over-read in lldpd allows attackers to cause denial of service or disclose memory contents via crafted VLAN frames.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-46433?
CVE-2026-46433 is a medium-severity memory corruption vulnerability in lldpd, published on 9 Jun 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
lldpd is an implementation of IEEE 802.1ab (LLDP). Prior to version 1.0.22, lldpd_decode() in src/daemon/lldpd.c strips 802.1Q VLAN tags from received Ethernet frames by calling memmove() to shift the frame payload 4 bytes left. The third argument (byte count) is s - 2 * ETHER_ADDR_LEN but should be s - 2 * ETHER_ADDR_LEN - 4, causing a 4-byte heap buffer over-read past the malloc(h_mtu) allocation when the received frame size equals the interface MTU. This issue has been patched in version 1.0.22.
Weakness: CWE-125
Which versions are affected by CVE-2026-46433?
It affects 1 product.
Linux distribution packages (2)
lldpd openSUSE:Leap 16.0 | All versions | 1.0.22-bp160.1.1 |
lldpd openSUSE:Tumbleweed | All versions | 1.0.22-1.1 |
Products include Lldpd Project Lldpd.
How do I fix CVE-2026-46433?
Upgrade to a fixed version.
Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.
Is CVE-2026-46433 being exploited?
There is no known exploitation of CVE-2026-46433 in the wild and no public exploit code.
Other vulnerabilities in lldpd
Sources
Also known as AZL-89700, CLSA-2026-1781628379, CLSA-2026-1782221091, DEBIAN-CVE-2026-46433, GHSA-2g8p-2h3j-63m3, UBUNTU-CVE-2026-46433 and 2 more.