# CVE-2026-46433: lldpd: Heap OOB Read in VLAN Decapsulation memmove

> A heap buffer over-read in lldpd allows attackers to cause denial of service or disclose memory contents via crafted VLAN frames.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Jun 2026
- **Updated:** 10 Jun 2026
- **Also known as:** AZL-89700, CLSA-2026-1781628379, CLSA-2026-1782221091, DEBIAN-CVE-2026-46433, GHSA-2g8p-2h3j-63m3, UBUNTU-CVE-2026-46433, openSUSE-SU-2026:10794-1, openSUSE-SU-2026:21146-1

## What is CVE-2026-46433?

CVE-2026-46433 is a medium-severity memory corruption vulnerability in lldpd, published on 9 Jun 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

lldpd is an implementation of IEEE 802.1ab (LLDP). Prior to version 1.0.22, lldpd_decode() in src/daemon/lldpd.c strips 802.1Q VLAN tags from received Ethernet frames by calling memmove() to shift the frame payload 4 bytes left. The third argument (byte count) is s - 2 * ETHER_ADDR_LEN but should be s - 2 * ETHER_ADDR_LEN - 4, causing a 4-byte heap buffer over-read past the malloc(h_mtu) allocation when the received frame size equals the interface MTU. This issue has been patched in version 1.0.22.

Weakness: CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2026-46433?

It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `lldpd` | openSUSE:Leap 16.0 | All versions | 1.0.22-bp160.1.1 |
| `lldpd` | openSUSE:Tumbleweed | All versions | 1.0.22-1.1 |

Products: Lldpd Project Lldpd.

## How do I fix CVE-2026-46433?

Upgrade to a fixed version.

## Is CVE-2026-46433 being exploited?

There is no known exploitation of CVE-2026-46433 in the wild and no public exploit code.

## Other vulnerabilities in lldpd

- [CVE-2023-41910](https://insights.sbomify.com/CVE-2023-41910/): Memory corruption in n/a (critical 9.8)
- [CVE-2015-8012](https://insights.sbomify.com/CVE-2015-8012/): Denial of service in n/a (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-46433 and fix it if it is affected.

What it is: CVE-2026-46433 is a medium-severity memory corruption vulnerability in lldpd, published on 9 Jun 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-46433 in the wild and no public exploit code.

Affected product: lldpd. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-46433/ (Markdown: https://insights.sbomify.com/CVE-2026-46433/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-46433
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-46433
- OSV: https://osv.dev/vulnerability/CVE-2026-46433

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-46433/
Summaries are generated and may contain mistakes; the official description above is the record.
