CVE-2026-46439 compliance-trestle Vulnerable to Remote Code Execution via Recursive Server-Side Template Injection (SSTI)

High 7.8 Published Updated

Attackers can execute arbitrary code by injecting malicious payloads into data fields rendered by the trestle author jinja command due to recursive template evaluation.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Local or same network only
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2026-46439?

CVE-2026-46439 is a high-severity code injection vulnerability in oscal-compass compliance-trestle, published on 14 Aug 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

Official description

compliance-trestle is a tooling platform for managing compliance as code. Versions prior to 3.12.2 and 4.0.3 have a Server-Side Template Injection (SSTI) vulnerability exists in the `trestle author jinja` command. The command recursively evaluates rendered templates, allowing an attacker to achieve arbitrary command execution with privileges of the running process by injecting malicious payloads into data fields (such as SSP documents or Lookup Tables). The vulnerability does not require attacker control of the template itself. Only attacker-controlled input data rendered into a trusted template is required. This distinction is critical: the template author may only intend to render plain text (e.g., `Title: {{ ssp.metadata.title }}`), but because of the recursive parsing, the data field itself becomes executable. The vulnerability is caused by recursive re-compilation and re-rendering of already-rendered output. Versions 3.12.3 and 4.0.3 patch the issue.

Weakness: CWE-94, CWE-1336

Which versions are affected by CVE-2026-46439?

5 open source packages ship an affected version, including compliance-trestle.

PackageAffectedFixed in
compliance-trestle PyPIAll versions3.12.2, 4.0.3
compliance-trestle PyPIAll versions3.12.2
compliance-trestle PyPIAll versions3.12.2
compliance-trestle PyPIFrom 4.0.04.0.3
compliance-trestle PyPIFrom 4.0.04.0.3

How do I fix CVE-2026-46439?

Upgrade compliance-trestle to a fixed version for your release line: 3.12.2 or 4.0.3.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2026-46439 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-46439 exists.

Sources

Also known as GHSA-gg2g-p7xc-qqmm, PYSEC-2026-2425.

Is CVE-2026-46439 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free