{"answers":{"affected":"5 open source packages ship an affected version, including compliance-trestle.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-46439 exists.","fix":"Upgrade compliance-trestle to a fixed version for your release line: 3.12.2 or 4.0.3.","what":"CVE-2026-46439 is a high-severity code injection vulnerability in oscal-compass compliance-trestle, published on 14 Aug 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-46439 and fix it if it is affected.\n\nWhat it is: CVE-2026-46439 is a high-severity code injection vulnerability in oscal-compass compliance-trestle, published on 14 Aug 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-46439 exists.\n\nAffected packages and fixed versions:\n- compliance-trestle (PyPI): affected all versions; fixed in 3.12.2, 4.0.3\n- compliance-trestle (PyPI): affected all versions; fixed in 3.12.2\n- compliance-trestle (PyPI): affected all versions; fixed in 3.12.2\n- compliance-trestle (PyPI): affected from 4.0.0; fixed in 4.0.3\n- compliance-trestle (PyPI): affected from 4.0.0; fixed in 4.0.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-46439/ (Markdown: https://insights.sbomify.com/CVE-2026-46439/index.md)","id":"CVE-2026-46439","markdown":"https://insights.sbomify.com/CVE-2026-46439/index.md","name":"CVE-2026-46439","record":{"aliases":["GHSA-gg2g-p7xc-qqmm","PYSEC-2026-2425"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Compliance as code tool","requires_auth":"none","summary":"Attackers can execute arbitrary code by injecting malicious payloads into data fields rendered by the trestle author jinja command due to recursive template evaluation.","user_interaction":"required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"},{"id":"CWE-1336","name":"Improper Neutralization of Special Elements Used in a Template Engine"}],"description":"compliance-trestle is a tooling platform for managing compliance as code. Versions prior to 3.12.2 and 4.0.3 have a Server-Side Template Injection (SSTI) vulnerability exists in the `trestle author jinja` command. The command recursively evaluates rendered templates, allowing an attacker to achieve arbitrary command execution with privileges of the running process by injecting malicious payloads into data fields (such as SSP documents or Lookup Tables). The vulnerability does not require attacker control of the template itself. Only attacker-controlled input data rendered into a trusted template is required. This distinction is critical: the template author may only intend to render plain text (e.g., `Title: {{ ssp.metadata.title }}`), but because of the recursive parsing, the data field itself becomes executable. The vulnerability is caused by recursive re-compilation and re-rendering of already-rendered output. Versions 3.12.3 and 4.0.3 patch the issue.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"compliance-trestle Vulnerable to Remote Code Execution via Recursive Server-Side Template Injection (SSTI)","id":"CVE-2026-46439","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"code_injection","year":"2026"},"n_packages":5,"n_references":4,"next":{"headline":"Flowise: Basic Auth Credentials Exposed via API","id":"CVE-2026-46440"},"packages":[{"ecosystem":"PyPI","fixed":["3.12.2","4.0.3"],"introduced":["0","4.0.0"],"last_affected":[],"package":"compliance-trestle","purl":"pkg:pypi/compliance-trestle","source":"PYSEC-2026-2425"},{"ecosystem":"PyPI","fixed":["3.12.2"],"introduced":["0"],"last_affected":[],"package":"compliance-trestle","purl":null,"source":"GHSA-gg2g-p7xc-qqmm"},{"ecosystem":"PyPI","fixed":["3.12.2"],"introduced":["0"],"last_affected":[],"package":"compliance-trestle","purl":"pkg:pypi/compliance-trestle","source":"GHSA-gg2g-p7xc-qqmm"},{"ecosystem":"PyPI","fixed":["4.0.3"],"introduced":["4.0.0"],"last_affected":[],"package":"compliance-trestle","purl":null,"source":"GHSA-gg2g-p7xc-qqmm"},{"ecosystem":"PyPI","fixed":["4.0.3"],"introduced":["4.0.0"],"last_affected":[],"package":"compliance-trestle","purl":"pkg:pypi/compliance-trestle","source":"GHSA-gg2g-p7xc-qqmm"}],"prev":{"headline":"wger: Cross-User Data Corruption via Missing Ownership Check on WorkoutLog.slot_entry","id":"CVE-2026-46438"},"products":["compliance-trestle"],"published":"2026-08-14","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-08-14","vendors":["oscal-compass"]},"summary":"Attackers can execute arbitrary code by injecting malicious payloads into data fields rendered by the trestle author jinja command due to recursive template evaluation.","url":"https://insights.sbomify.com/CVE-2026-46439/"}