# CVE-2026-46439: compliance-trestle Vulnerable to Remote Code Execution via Recursive Server-Side Template Injection (SSTI)

> Attackers can execute arbitrary code by injecting malicious payloads into data fields rendered by the trestle author jinja command due to recursive template evaluation.

- **Severity:** High 7.8 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 14 Aug 2026
- **Updated:** 14 Aug 2026
- **Also known as:** GHSA-gg2g-p7xc-qqmm, PYSEC-2026-2425

## What is CVE-2026-46439?

CVE-2026-46439 is a high-severity code injection vulnerability in oscal-compass compliance-trestle, published on 14 Aug 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

compliance-trestle is a tooling platform for managing compliance as code. Versions prior to 3.12.2 and 4.0.3 have a Server-Side Template Injection (SSTI) vulnerability exists in the `trestle author jinja` command. The command recursively evaluates rendered templates, allowing an attacker to achieve arbitrary command execution with privileges of the running process by injecting malicious payloads into data fields (such as SSP documents or Lookup Tables). The vulnerability does not require attacker control of the template itself. Only attacker-controlled input data rendered into a trusted template is required. This distinction is critical: the template author may only intend to render plain text (e.g., `Title: {{ ssp.metadata.title }}`), but because of the recursive parsing, the data field itself becomes executable. The vulnerability is caused by recursive re-compilation and re-rendering of already-rendered output. Versions 3.12.3 and 4.0.3 patch the issue.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-1336 (Improper Neutralization of Special Elements Used in a Template Engine)

## Which versions are affected by CVE-2026-46439?

5 open source packages ship an affected version, including compliance-trestle.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `compliance-trestle` | PyPI | All versions | 3.12.2, 4.0.3 |
| `compliance-trestle` | PyPI | All versions | 3.12.2 |
| `compliance-trestle` | PyPI | All versions | 3.12.2 |
| `compliance-trestle` | PyPI | From 4.0.0 | 4.0.3 |
| `compliance-trestle` | PyPI | From 4.0.0 | 4.0.3 |

## How do I fix CVE-2026-46439?

Upgrade compliance-trestle to a fixed version for your release line: 3.12.2 or 4.0.3.

## Is CVE-2026-46439 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-46439 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-46439 and fix it if it is affected.

What it is: CVE-2026-46439 is a high-severity code injection vulnerability in oscal-compass compliance-trestle, published on 14 Aug 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-46439 exists.

Affected packages and fixed versions:
- compliance-trestle (PyPI): affected all versions; fixed in 3.12.2, 4.0.3
- compliance-trestle (PyPI): affected all versions; fixed in 3.12.2
- compliance-trestle (PyPI): affected all versions; fixed in 3.12.2
- compliance-trestle (PyPI): affected from 4.0.0; fixed in 4.0.3
- compliance-trestle (PyPI): affected from 4.0.0; fixed in 4.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-46439/ (Markdown: https://insights.sbomify.com/CVE-2026-46439/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-46439
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-46439
- OSV: https://osv.dev/vulnerability/CVE-2026-46439

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-46439/
Summaries are generated and may contain mistakes; the official description above is the record.
