# CVE-2026-46442: Flowise: Authenticated Host RCE via POST /api/v1/node-custom-function and NodeVM Sandbox Escape

> Authenticated attackers can execute arbitrary system commands on the host by submitting malicious JavaScript to the custom function endpoint, bypassing the NodeVM sandbox.

- **Severity:** Critical 9.4 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Jun 2026
- **Updated:** 9 Jun 2026
- **Also known as:** GHSA-9rvc-vf7m-pgm2

## What is CVE-2026-46442?

CVE-2026-46442 is a critical code injection vulnerability in Flowiseai Flowise, published on 8 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Flowise is a drag & drop user interface to build a customized large language model flow. Prior to version 3.1.2, POST /api/v1/node-custom-function lacks route-level authorization, allowing any authenticated user or API key to submit arbitrary JavaScript to the Custom JS Function node. When E2B_APIKEY is not configured — the common deployment case — Flowise executes this code inside a NodeVM sandbox. This sandbox can be escaped, allowing an attacker to reach the host process object and execute system commands via child_process. The result is authenticated remote code execution on the Flowise server host. This issue has been patched in version 3.1.2.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2026-46442?

2 open source packages ship an affected version, including flowise. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `flowise` | npm | All versions | 3.1.2 |
| `flowise` | npm | All versions | 3.1.2 |

Products: Flowiseai Flowise.

## How do I fix CVE-2026-46442?

Upgrade flowise to 3.1.2 or later.

## Is CVE-2026-46442 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-46442 exists.

Public exploit code:

- Academic proof-of-concept demonstrating CVE-2026-46442 for authorized security research. (github_poc): https://github.com/codeb0ssx/CVE-2026-46442-PoC
- Flowise < 3.1.2 - node-custom-function Unauthorized RCE (nuclei): http/cves/2026/CVE-2026-46442.yaml

## Other vulnerabilities in Flowiseai Flowise

- [CVE-2025-71338](https://insights.sbomify.com/CVE-2025-71338/): Flowise through 2.2.7 - Arbitrary File Write to Remote Code Execution via document-store API (critical 10.0)
- [CVE-2026-40933](https://insights.sbomify.com/CVE-2026-40933/): Flowise: Authenticated RCE Via MCP Adapters (critical 10.0)
- [CVE-2025-61913](https://insights.sbomify.com/CVE-2025-61913/): Flowise is vulnerable to arbitrary file read, arbitrary file write (critical 10.0)
- [CVE-2025-59528](https://insights.sbomify.com/CVE-2025-59528/): Flowise has Remote Code Execution vulnerability (critical 10.0)
- [CVE-2026-52098](https://insights.sbomify.com/CVE-2026-52098/): Code injection in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-46442 and fix it if it is affected.

What it is: CVE-2026-46442 is a critical code injection vulnerability in Flowiseai Flowise, published on 8 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-46442 exists.

Affected packages and fixed versions:
- flowise (npm): affected all versions; fixed in 3.1.2
- flowise (npm): affected all versions; fixed in 3.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-46442/ (Markdown: https://insights.sbomify.com/CVE-2026-46442/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-46442
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-46442
- OSV: https://osv.dev/vulnerability/CVE-2026-46442

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-46442/
Summaries are generated and may contain mistakes; the official description above is the record.
