# CVE-2026-46454: Apache Camel-Cometd: Inbound Bayeux message headers are mapped into the Exchange without a HeaderFilterStrategy, allowing unauthenticated clients to inject Camel control headers

> Unauthenticated attackers can inject Camel control headers via CometD messages, potentially redirecting producers or modifying data flow in Apache Camel routes.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Jul 2026
- **Updated:** 6 Jul 2026
- **Also known as:** GHSA-r9cc-j7wr-p329

## What is CVE-2026-46454?

CVE-2026-46454 is a critical vulnerability in Apache Camel, published on 6 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Improper Input Validation vulnerability in Apache Camel Cometd Component.

The camel-cometd component maps inbound Bayeux (CometD) message headers into the Camel Exchange without applying a HeaderFilterStrategy. CometdBinding.populateExchangeFromMessage copies the entire ext.CamelHeaders map supplied by the CometD client directly onto the Camel message (message.setHeaders), so any header name - including Camel-internal control headers such as CamelHttpUri, CamelFileName or CamelJmsDestinationName - is accepted unmodified. Because a CometdComponent installs no Bayeux SecurityPolicy by default, any client that can complete the Bayeux handshake against the CometD endpoint can publish such a message without authentication. An attacker can therefore inject arbitrary Camel control headers that influence the behaviour of downstream producers in the route (for example redirecting an HTTP producer, changing a file name, or overriding a JMS destination); the injected headers also persist across internal direct, seda and vm hops. The concrete downstream impact depends on which producers the route uses.
This issue affects Apache Camel: from 4.0.0 before 4.14.8, from 4.15.0 before 4.18.3, from 4.19.0 before 4.21.0.

Users are recommended to upgrade to version 4.21.0, which fixes the issue. If users are on the 4.14.x LTS releases stream, then they are suggested to upgrade to 4.14.8. If users are on the 4.18.x releases stream, then they are suggested to upgrade to 4.18.3. The fix implements a HeaderFilterStrategy in the camel-cometd binding (a long-standing TODO in the code) that filters the Camel header namespace case-insensitively on inbound mapping, so client-supplied Camel* / camel* headers are no longer copied into the Exchange. For deployments that cannot upgrade immediately, strip the Camel control headers from inbound CometD messages before they reach any downstream producer (for example removeHeaders('Camel*') and removeHeaders('camel*') at the start of the route), and install an explicit Bayeux SecurityPolicy on the CometdComponent so that only authenticated clients can publish.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-46454?

6 open source packages ship an affected version, including org.apache.camel:camel-cometd. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.camel:camel-cometd` | Maven | From 4.0.0 | 4.14.8 |
| `org.apache.camel:camel-cometd` | Maven | From 4.0.0 | 4.14.8 |
| `org.apache.camel:camel-cometd` | Maven | From 4.15.0 | 4.18.3 |
| `org.apache.camel:camel-cometd` | Maven | From 4.15.0 | 4.18.3 |
| `org.apache.camel:camel-cometd` | Maven | From 4.19.0 | 4.21.0 |
| `org.apache.camel:camel-cometd` | Maven | From 4.19.0 | 4.21.0 |

Products: Apache Camel.

## How do I fix CVE-2026-46454?

Upgrade org.apache.camel:camel-cometd to a fixed version for your release line: 4.14.8, 4.18.3 or 4.21.0.

## Is CVE-2026-46454 being exploited?

There is no known exploitation of CVE-2026-46454 in the wild and no public exploit code.

Public exploit code:

- Reproducer for CVE-2026-46454 — Apache Camel camel-cometd inbound Bayeux header injection (unauthenticated Camel control-header injection → downstream producer steering / RCE) (github_poc): https://github.com/oscerd/CVE-2026-46454

## Other vulnerabilities in Apache Camel

- [CVE-2026-33453](https://insights.sbomify.com/CVE-2026-33453/): Apache camel-coap allows header injection that can lead to remote code execution (critical 10.0)
- [CVE-2026-40453](https://insights.sbomify.com/CVE-2026-40453/): Apache Camel has an incomplete fix for CVE-2025-27636 (critical 9.9)
- [CVE-2026-80351](https://insights.sbomify.com/CVE-2026-80351/): Apache Camel K: Camel K Tenant repositories reach Maven execution inside operator pod (critical 9.8)
- [CVE-2026-80352](https://insights.sbomify.com/CVE-2026-80352/): Apache Camel K: Camel K Master trait serviceAccountName YAML injection lets CR author apply arbitrary objects (critical 9.8)
- [CVE-2026-71300](https://insights.sbomify.com/CVE-2026-71300/): Apache Camel: Camel-Atmosphere-Websocket: WebSocket dispatch header injection (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-46454 and fix it if it is affected.

What it is: CVE-2026-46454 is a critical vulnerability in Apache Camel, published on 6 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-46454 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.camel:camel-cometd (Maven): affected from 4.0.0; fixed in 4.14.8
- org.apache.camel:camel-cometd (Maven): affected from 4.0.0; fixed in 4.14.8
- org.apache.camel:camel-cometd (Maven): affected from 4.15.0; fixed in 4.18.3
- org.apache.camel:camel-cometd (Maven): affected from 4.15.0; fixed in 4.18.3
- org.apache.camel:camel-cometd (Maven): affected from 4.19.0; fixed in 4.21.0
- org.apache.camel:camel-cometd (Maven): affected from 4.19.0; fixed in 4.21.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-46454/ (Markdown: https://insights.sbomify.com/CVE-2026-46454/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-46454
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-46454
- OSV: https://osv.dev/vulnerability/CVE-2026-46454

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-46454/
Summaries are generated and may contain mistakes; the official description above is the record.
