CVE-2026-46455 Apache Camel-Keycloak: The access-token validity window is not verified because the IS_ACTIVE check is missing from the TokenVerifier, allowing expired tokens to be accepted

Critical 9.8 Published Updated

Attackers can use expired or not-yet-valid access tokens to bypass authentication in Apache Camel Keycloak integrations due to missing validity checks.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-46455?

CVE-2026-46455 is a critical authentication bypass vulnerability in Apache Camel, published on 6 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Insufficient Session Expiration vulnerability in Apache Camel Keycloak Component.

The camel-keycloak security helper KeycloakSecurityHelper.parseAndVerifyAccessToken builds a Keycloak TokenVerifier using withChecks(...) with only the subject-exists check and the realm-URL (issuer) check. Keycloak's TokenVerifier.withChecks(...) appends to an initially empty check list - the upstream default checks are installed only when withDefaultChecks() is called - so the built-in IS_ACTIVE predicate, which validates the token's exp (expiration) and nbf (not-before) claims, is never applied. As a result the helper verifies the token signature, subject and issuer but does not enforce the token's validity window: an access token that is expired, or not yet valid, is accepted as valid. Routes that rely on this helper to authenticate inbound requests therefore accept access tokens that are outside their intended lifetime. This issue affects Apache Camel: from 4.18.0 before 4.18.3, from 4.19.0 before 4.21.0.

Users are recommended to upgrade to version 4.21.0, which fixes the issue. If users are on the 4.18.x releases stream, then they are suggested to upgrade to 4.18.3. The fix makes KeycloakSecurityHelper.parseAndVerifyAccessToken include the TokenVerifier.IS_ACTIVE check so that expired or not-yet-valid access tokens are rejected, aligning the helper with Keycloak's default check set. For deployments that cannot upgrade immediately, enforce token expiration outside the helper - for example validate the access token's exp/nbf claims in the route before trusting it, keep Keycloak access-token lifetimes short, and ensure any upstream gateway or resource server also validates the token validity window.

Weakness: CWE-613

Which versions are affected by CVE-2026-46455?

4 open source packages ship an affected version, including org.apache.camel:camel-keycloak. It affects 1 product.

PackageAffectedFixed in
org.apache.camel:camel-keycloak MavenFrom 4.18.04.18.3
org.apache.camel:camel-keycloak MavenFrom 4.18.04.18.3
org.apache.camel:camel-keycloak MavenFrom 4.19.04.21.0
org.apache.camel:camel-keycloak MavenFrom 4.19.04.21.0

Products include Apache Camel.

How do I fix CVE-2026-46455?

Upgrade org.apache.camel:camel-keycloak to a fixed version for your release line: 4.18.3 or 4.21.0.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2026-46455 being exploited?

There is no known exploitation of CVE-2026-46455 in the wild and no public exploit code.

Public exploit code: 1 proofs of concept on GitHub.

All Apache Camel vulnerabilities

Sources

Also known as GHSA-mqwc-6qwc-v9gq.

Is CVE-2026-46455 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free