CVE-2026-46479 Flowise: Evaluation create+update mass-assignment allows cross-workspace evaluation takeover
High 7.7
Published
Updated
Check this codebase for CVE-2026-46479 and fix it if it is affected.
What it is: CVE-2026-46479 is a high-severity vulnerability in Flowiseai Flowise, published on 8 Jun 2026.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-46479 exists.
Affected packages and fixed versions:
- flowise (npm): affected all versions; fixed in 3.1.2
- flowise (npm): affected all versions; fixed in 3.1.2
Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.
Reference: https://insights.sbomify.com/CVE-2026-46479/ (Markdown: https://insights.sbomify.com/CVE-2026-46479/index.md)
- Exploited in the wild
- Not known
- Fix
- Available
What is CVE-2026-46479?
CVE-2026-46479 is a high-severity vulnerability in Flowiseai Flowise, published on 8 Jun 2026.
Official description
Flowise is a drag & drop user interface to build a customized large language model flow. Prior to version 3.1.2, evaluation create and update mass-assignment allows cross-workspace evaluation takeover. This issue has been patched in version 3.1.2.
Weakness: CWE-915
Which versions are affected by CVE-2026-46479?
2 open source packages ship an affected version, including flowise. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
flowise npm | All versions | 3.1.2 |
flowise npm | All versions | 3.1.2 |
Products include Flowiseai Flowise.
How do I fix CVE-2026-46479?
Upgrade flowise to 3.1.2 or later.
Is CVE-2026-46479 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-46479 exists.
Other vulnerabilities in Flowiseai Flowise
- CVE-2025-71338 Flowise through 2.2.7 - Arbitrary File Write to Remote Code Execution via document-store API
- CVE-2026-40933 Flowise: Authenticated RCE Via MCP Adapters
- CVE-2025-61913 Flowise is vulnerable to arbitrary file read, arbitrary file write
- CVE-2025-59528 Flowise has Remote Code Execution vulnerability
- CVE-2026-52098 Code injection in n/a
Sources
Also known as GHSA-mq53-pc65-wjc4.