# CVE-2026-46485: Dash: Users can write to config despire permissions (OIDC tested)

> Unauthenticated or non-admin users can modify the main configuration file in Dashy deployments using OIDC, leading to unauthorized changes and potential service disruption.

- **Severity:** High 8.2 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 15 Jul 2026
- **Updated:** 20 Jul 2026
- **Also known as:** GHSA-vjj9-fmvr-6h3p

## What is CVE-2026-46485?

CVE-2026-46485 is a high-severity missing authorization vulnerability in lissy93 dashy, published on 15 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Dashy is a self-hostable personal dashboard. Prior to 4.0.8, Dashy deployments using OIDC can allow unauthenticated users or non-admin authenticated users to write changes to the main config.yaml through the config-saving functionality despite configured permissions, allowing unauthorized modification of dashboard configuration and potential service disruption. This issue is fixed in version 4.0.8.

Weakness: CWE-602 (Client-Side Enforcement of Server-Side Security), CWE-287 (Improper Authentication), CWE-284 (Improper Access Control), CWE-15 (External Control of System or Configuration Setting)

## Which versions are affected by CVE-2026-46485?


## How do I fix CVE-2026-46485?

No fix has been published for CVE-2026-46485 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-46485 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-46485 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-46485 and fix it if it is affected.

What it is: CVE-2026-46485 is a high-severity missing authorization vulnerability in lissy93 dashy, published on 15 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-46485 exists.

Affected product: lissy93 dashy. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-46485/ (Markdown: https://insights.sbomify.com/CVE-2026-46485/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-46485
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-46485
- OSV: https://osv.dev/vulnerability/CVE-2026-46485

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-46485/
Summaries are generated and may contain mistakes; the official description above is the record.
