{"answers":{"affected":"3 open source packages ship an affected version, including lmdeploy.","exploited":"There is no known exploitation of CVE-2026-46517 in the wild and no public exploit code.","fix":"Upgrade lmdeploy to 0.13.0 or later.","what":"CVE-2026-46517 is a high-severity code injection vulnerability in InternLM lmdeploy, published on 9 Jun 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-46517 and fix it if it is affected.\n\nWhat it is: CVE-2026-46517 is a high-severity code injection vulnerability in InternLM lmdeploy, published on 9 Jun 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-46517 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- lmdeploy (PyPI): affected all versions up to 0.12.3; no fix listed\n- lmdeploy (PyPI): affected all versions; fixed in 0.13.0\n- lmdeploy (PyPI): affected all versions; fixed in 0.13.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-46517/ (Markdown: https://insights.sbomify.com/CVE-2026-46517/index.md)","id":"CVE-2026-46517","markdown":"https://insights.sbomify.com/CVE-2026-46517/index.md","name":"CVE-2026-46517","record":{"aliases":["GHSA-9xq9-36w5-q796","PYSEC-2026-2608"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"LLM deployment toolkit","requires_auth":"none","summary":"Hardcoded trust_remote_code setting allows remote code execution via Hugging Face supply chain without user consent.","user_interaction":"required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"},{"id":"CWE-915","name":"Improperly Controlled Modification of Dynamically-Determined Object Attributes"},{"id":"CWE-1188","name":"Initialization of a Resource with an Insecure Default"}],"description":"LMDeploy is a toolkit for compressing, deploying, and serving large language models. In versions 0.12.3 and prior, hardcoded \"trust_remote_code=True\" enables HF supply-chain RCE without user opt-in. Version 0.13.0 patches the issue.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"LMDeploy: Hardcoded trust_remote_code=True is an implicit unsafe remote-code load path with no user opt-out","id":"CVE-2026-46517","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"code_injection","year":"2026"},"n_packages":3,"n_references":6,"next":{"headline":"OpenEMR: Stored XSS in prescription CSS/HTML print view via patient demographics","id":"CVE-2026-46518"},"packages":[{"ecosystem":"PyPI","fixed":[],"introduced":["0"],"last_affected":["0.12.3"],"package":"lmdeploy","purl":"pkg:pypi/lmdeploy","source":"PYSEC-2026-2608"},{"ecosystem":"PyPI","fixed":["0.13.0"],"introduced":["0"],"last_affected":[],"package":"lmdeploy","purl":null,"source":"GHSA-9xq9-36w5-q796"},{"ecosystem":"PyPI","fixed":["0.13.0"],"introduced":["0"],"last_affected":[],"package":"lmdeploy","purl":"pkg:pypi/lmdeploy","source":"GHSA-9xq9-36w5-q796"}],"prev":{"headline":"Frogman vulnerable to stored XSS in chat console formatter (escalation vector in multi-admin deployments)","id":"CVE-2026-46516"},"products":["lmdeploy"],"published":"2026-06-09","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-08-31","vendors":["InternLM"]},"summary":"Hardcoded trust_remote_code setting allows remote code execution via Hugging Face supply chain without user consent.","url":"https://insights.sbomify.com/CVE-2026-46517/"}