# CVE-2026-46517: LMDeploy: Hardcoded trust_remote_code=True is an implicit unsafe remote-code load path with no user opt-out

> Hardcoded trust_remote_code setting allows remote code execution via Hugging Face supply chain without user consent.

- **Severity:** High 7.8 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 9 Jun 2026
- **Updated:** 31 Aug 2026
- **Also known as:** GHSA-9xq9-36w5-q796, PYSEC-2026-2608

## What is CVE-2026-46517?

CVE-2026-46517 is a high-severity code injection vulnerability in InternLM lmdeploy, published on 9 Jun 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

LMDeploy is a toolkit for compressing, deploying, and serving large language models. In versions 0.12.3 and prior, hardcoded "trust_remote_code=True" enables HF supply-chain RCE without user opt-in. Version 0.13.0 patches the issue.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-915 (Improperly Controlled Modification of Dynamically-Determined Object Attributes), CWE-1188 (Initialization of a Resource with an Insecure Default)

## Which versions are affected by CVE-2026-46517?

3 open source packages ship an affected version, including lmdeploy.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `lmdeploy` | PyPI | All versions to 0.12.3 | None |
| `lmdeploy` | PyPI | All versions | 0.13.0 |
| `lmdeploy` | PyPI | All versions | 0.13.0 |

## How do I fix CVE-2026-46517?

Upgrade lmdeploy to 0.13.0 or later.

## Is CVE-2026-46517 being exploited?

There is no known exploitation of CVE-2026-46517 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-46517 and fix it if it is affected.

What it is: CVE-2026-46517 is a high-severity code injection vulnerability in InternLM lmdeploy, published on 9 Jun 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-46517 in the wild and no public exploit code.

Affected packages and fixed versions:
- lmdeploy (PyPI): affected all versions up to 0.12.3; no fix listed
- lmdeploy (PyPI): affected all versions; fixed in 0.13.0
- lmdeploy (PyPI): affected all versions; fixed in 0.13.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-46517/ (Markdown: https://insights.sbomify.com/CVE-2026-46517/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-46517
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-46517
- OSV: https://osv.dev/vulnerability/CVE-2026-46517

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-46517/
Summaries are generated and may contain mistakes; the official description above is the record.
