# CVE-2026-46518: OpenEMR: Stored XSS in prescription CSS/HTML print view via patient demographics

> Stored XSS in OpenEMR allows patient portal users to execute JavaScript in clinician sessions, enabling privilege escalation and session hijacking.

- **Severity:** High 7.7 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 9 Jun 2026
- **Updated:** 10 Jun 2026
- **Also known as:** GHSA-4gh4-q39r-45wf

## What is CVE-2026-46518?

CVE-2026-46518 is a high-severity cross-site scripting vulnerability in Open-Emr Openemr, published on 9 Jun 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

OpenEMR is a free and open source electronic health records and medical practice management application. Prior to version 8.0.0.1, a stored cross-site scripting vulnerability in the prescription CSS/HTML multi-print feature allows a patient portal user to execute arbitrary JavaScript in a clinician's browser session. Patient demographic fields (name, address) are rendered without output encoding in multiprintcss_header(), and portal patients can write attacker-controlled HTML directly into patient_data by calling the PUT api/patient/:num endpoint, which bypasses the intended audit review workflow. Because the XSS fires in the clinician's authenticated session on the main OpenEMR interface, the attacker can access CSRF tokens, session data, and perform actions as the clinician — crossing the patient-to-clinician trust boundary. This issue has been patched in version 8.0.0.1.

Weakness: CWE-862 (Missing Authorization), CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-46518?

It affects 1 product.


Products: Open-Emr Openemr.

## How do I fix CVE-2026-46518?

No fix has been published for CVE-2026-46518 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-46518 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-46518 exists.

## Other vulnerabilities in Open-Emr Openemr

- [CVE-2026-24898](https://insights.sbomify.com/CVE-2026-24898/): OpenEMR has an Unauthenticated MedEx Token Disclosure (critical 10.0)
- [CVE-2026-24849](https://insights.sbomify.com/CVE-2026-24849/): OpenEMR Arbitrary File Read Vulnerability (critical 10.0)
- [CVE-2026-24908](https://insights.sbomify.com/CVE-2026-24908/): OpenEMR has SQL Injection in Patient API Sort Parameter (critical 10.0)
- [CVE-2022-2734](https://insights.sbomify.com/CVE-2022-2734/): Improper Restriction of Rendered UI Layers or Frames in openemr/openemr (critical 10.0)
- [CVE-2024-22611](https://insights.sbomify.com/CVE-2024-22611/): SQL injection in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-46518 and fix it if it is affected.

What it is: CVE-2026-46518 is a high-severity cross-site scripting vulnerability in Open-Emr Openemr, published on 9 Jun 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-46518 exists.

Affected product: Open-Emr Openemr. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-46518/ (Markdown: https://insights.sbomify.com/CVE-2026-46518/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-46518
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-46518
- OSV: https://osv.dev/vulnerability/CVE-2026-46518

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-46518/
Summaries are generated and may contain mistakes; the official description above is the record.
