{"answers":{"affected":"2 open source packages ship an affected version, including mcp-server-kubernetes.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-46519 exists.","fix":"Upgrade mcp-server-kubernetes to 3.6.0 or later.","what":"CVE-2026-46519 is a high-severity missing authorization vulnerability in Flux159 mcp-server-kubernetes, published on 11 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-46519 and fix it if it is affected.\n\nWhat it is: CVE-2026-46519 is a high-severity missing authorization vulnerability in Flux159 mcp-server-kubernetes, published on 11 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-46519 exists.\n\nAffected packages and fixed versions:\n- mcp-server-kubernetes (npm): affected all versions; fixed in 3.6.0\n- mcp-server-kubernetes (npm): affected all versions; fixed in 3.6.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-46519/ (Markdown: https://insights.sbomify.com/CVE-2026-46519/index.md)","id":"CVE-2026-46519","markdown":"https://insights.sbomify.com/CVE-2026-46519/index.md","name":"CVE-2026-46519","record":{"aliases":["GHSA-cr22-wjx7-2w6m","openSUSE-SU-2026:10914-1","openSUSE-SU-2026:21152-1"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["privilege_escalation","security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"Kubernetes MCP server","requires_auth":"low_privilege","summary":"Attackers can bypass Kubernetes operation restrictions in mcp-server-kubernetes by invoking tools directly, ignoring configured access controls.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-863","name":"Incorrect Authorization"}],"description":"mcp-server-kubernetes is a Model Context Protocol server for Kubernetes cluster management. Prior to version 3.6.0, mcp-server-kubernetes exposes three environment variables (ALLOW_ONLY_READONLY_TOOLS, ALLOW_ONLY_NON_DESTRUCTIVE_TOOLS, ALLOWED_TOOLS) documented as access controls for restricting which Kubernetes operations are available. These controls are enforced at the tool discovery layer (tools/list) but not at the execution layer (tools/call). Any client that knows a tool name can invoke it directly regardless of the configured restriction mode. The access control was effectively cosmetic. This issue has been patched in version 3.6.0.","ecosystems":["npm","openSUSE:Leap 16.0","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"MCP Server Kubernetes: Tool Access Control Bypass via Presentation-Layer Filtering Without Execution-Layer Enforcement","id":"CVE-2026-46519","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"missing_authorization","year":"2026"},"n_packages":4,"n_references":2,"next":{"headline":"ImageMagick: Heap Buffer Over-Write in IPL decoder when reading multiple images of different dimensions","id":"CVE-2026-46520"},"packages":[{"ecosystem":"npm","fixed":["3.6.0"],"introduced":["0"],"last_affected":[],"package":"mcp-server-kubernetes","purl":null,"source":"GHSA-cr22-wjx7-2w6m"},{"ecosystem":"npm","fixed":["3.6.0"],"introduced":["0"],"last_affected":[],"package":"mcp-server-kubernetes","purl":"pkg:npm/mcp-server-kubernetes","source":"GHSA-cr22-wjx7-2w6m"},{"ecosystem":"openSUSE:Leap 16.0","fixed":["1.28.4-bp160.1.1"],"introduced":["0"],"last_affected":[],"package":"atril","purl":"pkg:rpm/opensuse/atril\u0026distro=openSUSE%20Leap%2016.0","source":"openSUSE-SU-2026:21152-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["1.28.4-1.1"],"introduced":["0"],"last_affected":[],"package":"atril","purl":"pkg:rpm/opensuse/atril\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2026:10914-1"}],"prev":{"headline":"OpenEMR: Stored XSS in prescription CSS/HTML print view via patient demographics","id":"CVE-2026-46518"},"products":["mcp-server-kubernetes"],"published":"2026-06-11","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-06-11","vendors":["Flux159"]},"summary":"Attackers can bypass Kubernetes operation restrictions in mcp-server-kubernetes by invoking tools directly, ignoring configured access controls.","url":"https://insights.sbomify.com/CVE-2026-46519/"}