# CVE-2026-46531: Cacti is an open source performance and fault management framework.


- **Severity:** Medium 5.5 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 23 Oct 2026
- **Updated:** 29 Oct 2026
- **Also known as:** DEBIAN-CVE-2026-46531, GHSA-37jj-rx8x-4wf2, UBUNTU-CVE-2026-46531

## What is CVE-2026-46531?

CVE-2026-46531 is a medium-severity vulnerability in cacti, published on 23 Oct 2026. 

### Official description

Cacti is an open source performance and fault management framework. From version 1.2.27 to before version 1.2.31, Cacti contains an authenticated stored second-order SQL injection in the automation tree rule item handler. A user holding the Automation realm (default General Administration role) can persist an arbitrary SQL fragment in the automation_tree_rule_items.field column. The fragment is later concatenated directly into a SELECT ... AS source FROM ... clause in lib/api_automation.php :: create_all_header_nodes() and executed when an administrator triggers automation via the standard graphs.php?action=actions&drp_action=8 ("Apply Automation Rules") bulk action. The result of the injected SELECT is written into graph_tree_items.title and rendered in the Cacti tree UI, providing a direct exfiltration channe. This issue has been patched in version 1.2.31.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2026-46531?


## How do I fix CVE-2026-46531?

Upgrade to a fixed version.

## Is CVE-2026-46531 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-46531 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-46531 and fix it if it is affected.

What it is: CVE-2026-46531 is a medium-severity vulnerability in cacti, published on 23 Oct 2026. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-46531 exists.

Affected product: cacti. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-46531/ (Markdown: https://insights.sbomify.com/CVE-2026-46531/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-46531
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-46531
- OSV: https://osv.dev/vulnerability/CVE-2026-46531

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-46531/
Summaries are generated and may contain mistakes; the official description above is the record.
