# CVE-2026-46542: nimiq-keys: Denial of service in Ed25519 multisig delinearization via invalid curve points

> Attackers can crash the application by providing invalid Ed25519 public keys to the delinearization function, causing a panic.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 9 Jun 2026
- **Updated:** 10 Jun 2026
- **Also known as:** GHSA-h9cc-w26m-j342

## What is CVE-2026-46542?

CVE-2026-46542 is a medium-severity denial of service vulnerability in nimiq core-rs-albatross, published on 9 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Nimiq is a Rust implementation of the Nimiq Proof-of-Stake protocol based on the Albatross consensus algorithm. Prior to version 1.4.0, a denial-of-service vulnerability exists in the Ed25519 multisig delinearization code path. Ed25519PublicKey::delinearize() in keys/src/multisig/mod.rs called .unwrap() on curve point decompression, which panics when a public key is constructed from 32 bytes that do not represent a valid point on the Ed25519 curve. Ed25519PublicKey construction only validates byte length, not curve membership, so invalid keys can reach the delinearization path and crash the hosting process. This issue has been patched in version 1.4.0.

Weakness: CWE-617 (Reachable Assertion)

## Which versions are affected by CVE-2026-46542?

2 open source packages ship an affected version, including nimiq-keys.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nimiq-keys` | crates.io | All versions | 1.4.0 |
| `nimiq-keys` | crates.io | All versions | 1.4.0 |

## How do I fix CVE-2026-46542?

Upgrade nimiq-keys to 1.4.0 or later.

## Is CVE-2026-46542 being exploited?

There is no known exploitation of CVE-2026-46542 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-46542 and fix it if it is affected.

What it is: CVE-2026-46542 is a medium-severity denial of service vulnerability in nimiq core-rs-albatross, published on 9 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-46542 in the wild and no public exploit code.

Affected packages and fixed versions:
- nimiq-keys (crates.io): affected all versions; fixed in 1.4.0
- nimiq-keys (crates.io): affected all versions; fixed in 1.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-46542/ (Markdown: https://insights.sbomify.com/CVE-2026-46542/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-46542
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-46542
- OSV: https://osv.dev/vulnerability/CVE-2026-46542

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-46542/
Summaries are generated and may contain mistakes; the official description above is the record.
