# CVE-2026-46543: nimiq-blockchain: Genesis batch set request


- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 9 Jun 2026
- **Updated:** 10 Jun 2026
- **Also known as:** GHSA-vghx-352f-93jm

## What is CVE-2026-46543?

CVE-2026-46543 is a medium-severity vulnerability in nimiq core-rs-albatross, published on 9 Jun 2026. 

### Official description

Nimiq is a Rust implementation of the Nimiq Proof-of-Stake protocol based on the Albatross consensus algorithm. Prior to version 1.5.0, a remote peer can crash any full node by sending a RequestBatchSet message containing the genesis block's hash. The handler calls get_epoch_chunks which iterates backwards through macro blocks using Policy::macro_block_before. When it reaches the genesis block number, macro_block_before panics with "No macro blocks before genesis block". This issue has been patched in version 1.5.0.

Weakness: CWE-617 (Reachable Assertion)

## Which versions are affected by CVE-2026-46543?

2 open source packages ship an affected version, including nimiq-blockchain.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nimiq-blockchain` | crates.io | All versions | 1.5.0 |
| `nimiq-blockchain` | crates.io | All versions | 1.5.0 |

## How do I fix CVE-2026-46543?

Upgrade nimiq-blockchain to 1.5.0 or later.

## Is CVE-2026-46543 being exploited?

There is no known exploitation of CVE-2026-46543 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-46543 and fix it if it is affected.

What it is: CVE-2026-46543 is a medium-severity vulnerability in nimiq core-rs-albatross, published on 9 Jun 2026. 
Exploitation: There is no known exploitation of CVE-2026-46543 in the wild and no public exploit code.

Affected packages and fixed versions:
- nimiq-blockchain (crates.io): affected all versions; fixed in 1.5.0
- nimiq-blockchain (crates.io): affected all versions; fixed in 1.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-46543/ (Markdown: https://insights.sbomify.com/CVE-2026-46543/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-46543
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-46543
- OSV: https://osv.dev/vulnerability/CVE-2026-46543

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-46543/
Summaries are generated and may contain mistakes; the official description above is the record.
