# CVE-2026-46545: nimiq-primitives: Panic DoS in trie chunk processing via ROOT-keyed item


- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 9 Jun 2026
- **Updated:** 10 Jun 2026
- **Also known as:** GHSA-mw3q-r9wh-h2ff

## What is CVE-2026-46545?

CVE-2026-46545 is a high-severity vulnerability in nimiq core-rs-albatross, published on 9 Jun 2026. 

### Official description

Nimiq is a Rust implementation of the Nimiq Proof-of-Stake protocol based on the Albatross consensus algorithm. Prior to version 1.5.0, a remote, unauthenticated denial-of-service vulnerability in MerkleRadixTrie::put_chunk allows any state-sync peer to crash any node performing state synchronization (freshly joining nodes and recovering nodes). This issue has been patched in version 1.5.0.

Weakness: CWE-248 (Uncaught Exception)

## Which versions are affected by CVE-2026-46545?

2 open source packages ship an affected version, including nimiq-primitives.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nimiq-primitives` | crates.io | All versions | 1.5.0 |
| `nimiq-primitives` | crates.io | All versions | 1.5.0 |

## How do I fix CVE-2026-46545?

Upgrade nimiq-primitives to 1.5.0 or later.

## Is CVE-2026-46545 being exploited?

There is no known exploitation of CVE-2026-46545 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-46545 and fix it if it is affected.

What it is: CVE-2026-46545 is a high-severity vulnerability in nimiq core-rs-albatross, published on 9 Jun 2026. 
Exploitation: There is no known exploitation of CVE-2026-46545 in the wild and no public exploit code.

Affected packages and fixed versions:
- nimiq-primitives (crates.io): affected all versions; fixed in 1.5.0
- nimiq-primitives (crates.io): affected all versions; fixed in 1.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-46545/ (Markdown: https://insights.sbomify.com/CVE-2026-46545/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-46545
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-46545
- OSV: https://osv.dev/vulnerability/CVE-2026-46545

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-46545/
Summaries are generated and may contain mistakes; the official description above is the record.
