# CVE-2026-46548: NocoDB: SSRF Protection Bypass in Notification Webhook Plugins (Slack, Discord, Mattermost, Teams)

> Authenticated users can bypass SSRF protections in notification plugins to send requests to internal hosts, potentially exposing internal data.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 23 Jun 2026
- **Updated:** 24 Jun 2026
- **Also known as:** GHSA-2c5x-4jgf-88mj

## What is CVE-2026-46548?

CVE-2026-46548 is a medium-severity server-side request forgery vulnerability in nocodb, published on 23 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

NocoDB is software for building databases as spreadsheets. Prior to 2026.04.1, the request-filtering-agent SSRF protection was non-functional in the four notification webhook plugins (Slack, Discord, Mattermost, Teams) because httpAgent / httpsAgent were passed as part of the request body rather than the axios config. An authenticated user with hook-creation permission could direct outbound POST requests to arbitrary internal hosts. This vulnerability is fixed in 2026.04.1.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-46548?

2 open source packages ship an affected version, including nocodb.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nocodb` | npm | All versions to 0.301.3 | None |
| `nocodb` | npm | All versions to 0.301.3 | None |

## How do I fix CVE-2026-46548?

No fix has been published for CVE-2026-46548 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-46548 being exploited?

There is no known exploitation of CVE-2026-46548 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-46548 and fix it if it is affected.

What it is: CVE-2026-46548 is a medium-severity server-side request forgery vulnerability in nocodb, published on 23 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-46548 in the wild and no public exploit code.

Affected packages and fixed versions:
- nocodb (npm): affected all versions up to 0.301.3; no fix listed
- nocodb (npm): affected all versions up to 0.301.3; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-46548/ (Markdown: https://insights.sbomify.com/CVE-2026-46548/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-46548
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-46548
- OSV: https://osv.dev/vulnerability/CVE-2026-46548

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-46548/
Summaries are generated and may contain mistakes; the official description above is the record.
