# CVE-2026-46554: NocoDB: Stale Auth Cache After API Token Deletion


- **Severity:** Low 2.3 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:P/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 23 Jun 2026
- **Updated:** 24 Jun 2026
- **Also known as:** GHSA-f76x-f9vj-92jv

## What is CVE-2026-46554?

CVE-2026-46554 is a low-severity vulnerability in nocodb, published on 23 Jun 2026. 

### Official description

NocoDB is software for building databases as spreadsheets. Prior to 2026.04.4, deleted API tokens continued to authenticate requests until their cache entry expired, because the auth cache was not invalidated by token value at deletion time. The API token deletion path removed the database row but did not evict the token-value keyed entry from the auth cache. The auth middleware therefore continued to accept the deleted token until the cache entry aged out, leaving a deletion-to-revocation window of up to three days. This vulnerability is fixed in 2026.04.4.

Weakness: CWE-613 (DEPRECATED: Insufficient Session Expiration)

## Which versions are affected by CVE-2026-46554?

2 open source packages ship an affected version, including nocodb.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nocodb` | npm | All versions to 0.301.3 | None |
| `nocodb` | npm | All versions to 0.301.3 | None |

## How do I fix CVE-2026-46554?

No fix has been published for CVE-2026-46554 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-46554 being exploited?

There is no known exploitation of CVE-2026-46554 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-46554 and fix it if it is affected.

What it is: CVE-2026-46554 is a low-severity vulnerability in nocodb, published on 23 Jun 2026. 
Exploitation: There is no known exploitation of CVE-2026-46554 in the wild and no public exploit code.

Affected packages and fixed versions:
- nocodb (npm): affected all versions up to 0.301.3; no fix listed
- nocodb (npm): affected all versions up to 0.301.3; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-46554/ (Markdown: https://insights.sbomify.com/CVE-2026-46554/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-46554
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-46554
- OSV: https://osv.dev/vulnerability/CVE-2026-46554

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-46554/
Summaries are generated and may contain mistakes; the official description above is the record.
