# CVE-2026-46580: [Eclipse Theia] Indirect Prompt Injection via Auto-Loaded Workspace Prompt Template Files in AI Chat

> Attackers can inject malicious prompts via workspace files to execute arbitrary commands or exfiltrate data when opening untrusted repositories in Eclipse Theia.

- **Severity:** High 8.4 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 18 Jun 2026
- **Updated:** 19 Jun 2026
- **Also known as:** GHSA-m973-pr9r-hp2w, UBUNTU-CVE-2026-46580

## What is CVE-2026-46580?

CVE-2026-46580 is a high-severity code injection vulnerability in Eclipse Theia, published on 18 Jun 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

In Eclipse Theia versions prior to 1.71.0, files matching the pattern .prompts/*.prompttemplate in a workspace were automatically loaded and could override or extend the AI agent's system prompts. An attacker could craft a malicious repository containing prompt template files that, when the workspace was opened in Theia, replaced the AI's system instructions with attacker-controlled content (indirect prompt injection). Combined with other AI chat features available in untrusted workspaces, this enabled attack chains leading to data exfiltration via Markdown image rendering or arbitrary command execution via task definitions.

Weakness: CWE-829 (Inclusion of Functionality from Untrusted Control Sphere), CWE-1427 (Improper Neutralization of Input Used for LLM Prompting)

## Which versions are affected by CVE-2026-46580?

12 open source packages ship an affected version, including @theia/ai-chat, @theia/ai-chat-ui and @theia/ai-claude-code. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@theia/ai-chat` | npm | All versions | 1.71.0 |
| `@theia/ai-chat` | npm | All versions | 1.71.0 |
| `@theia/ai-chat-ui` | npm | All versions | 1.71.0 |
| `@theia/ai-chat-ui` | npm | All versions | 1.71.0 |
| `@theia/ai-claude-code` | npm | All versions | 1.71.0 |
| `@theia/ai-claude-code` | npm | All versions | 1.71.0 |
| `@theia/ai-code-completion` | npm | All versions | 1.71.0 |
| `@theia/ai-code-completion` | npm | All versions | 1.71.0 |
| `@theia/ai-core` | npm | All versions | 1.71.0 |
| `@theia/ai-core` | npm | All versions | 1.71.0 |
| `@theia/ai-editor` | npm | All versions | 1.71.0 |
| `@theia/ai-editor` | npm | All versions | 1.71.0 |

Products: Eclipse Theia.

## How do I fix CVE-2026-46580?

Upgrade @theia/ai-chat to 1.71.0 or later.

## Is CVE-2026-46580 being exploited?

There is no known exploitation of CVE-2026-46580 in the wild and no public exploit code.

## Other vulnerabilities in Eclipse Theia

- [CVE-2021-34436](https://insights.sbomify.com/CVE-2021-34436/): XML external entity in Eclipse Theia (critical 9.8)
- [CVE-2020-27224](https://insights.sbomify.com/CVE-2020-27224/): Cross-site Scripting (XSS) in Eclipse Theia (critical 9.6)
- [CVE-2026-60009](https://insights.sbomify.com/CVE-2026-60009/): File upload in Eclipse Theia (high 8.8)
- [CVE-2021-34435](https://insights.sbomify.com/CVE-2021-34435/): Remote code execution in Eclipse Theia (high 8.8)
- [CVE-2026-44688](https://insights.sbomify.com/CVE-2026-44688/): [Eclipse Theia] Indirect Prompt Injection via Adversarial Workspace File and Directory Names in AI Chat (high 8.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-46580 and fix it if it is affected.

What it is: CVE-2026-46580 is a high-severity code injection vulnerability in Eclipse Theia, published on 18 Jun 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-46580 in the wild and no public exploit code.

Affected packages and fixed versions:
- @theia/ai-chat (npm): affected all versions; fixed in 1.71.0
- @theia/ai-chat (npm): affected all versions; fixed in 1.71.0
- @theia/ai-chat-ui (npm): affected all versions; fixed in 1.71.0
- @theia/ai-chat-ui (npm): affected all versions; fixed in 1.71.0
- @theia/ai-claude-code (npm): affected all versions; fixed in 1.71.0
- @theia/ai-claude-code (npm): affected all versions; fixed in 1.71.0
- @theia/ai-code-completion (npm): affected all versions; fixed in 1.71.0
- @theia/ai-code-completion (npm): affected all versions; fixed in 1.71.0
- @theia/ai-core (npm): affected all versions; fixed in 1.71.0
- @theia/ai-core (npm): affected all versions; fixed in 1.71.0
- @theia/ai-editor (npm): affected all versions; fixed in 1.71.0
- @theia/ai-editor (npm): affected all versions; fixed in 1.71.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-46580/ (Markdown: https://insights.sbomify.com/CVE-2026-46580/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-46580
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-46580
- OSV: https://osv.dev/vulnerability/CVE-2026-46580

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-46580/
Summaries are generated and may contain mistakes; the official description above is the record.
