CVE-2026-46585 Apache Camel-Lucene: The query control headers used non-Camel-prefixed names (QUERY, RETURN_LUCENE_DOCS) that bypass the HTTP header filter, allowing an HTTP client to inject the full-text search query

High 7.5 Published Updated

Attackers can inject arbitrary Lucene queries via HTTP headers to read unauthorized data or cause denial of service in Apache Camel applications.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-46585?

CVE-2026-46585 is a high-severity missing authorization vulnerability in Apache Camel, published on 6 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Improper Input Validation, Authorization Bypass Through User-Controlled Key vulnerability in Apache Camel Lucene Component.

The camel-lucene producer reads the search phrase from an Exchange header (LuceneConstants.HEADER_QUERY) whose value was the plain string QUERY (and RETURN_LUCENE_DOCS for HEADER_RETURN_LUCENE_DOCS). Because these names do not start with the Camel / camel prefix, HttpHeaderFilterStrategy - which blocks only the Camel header namespace on the HTTP boundary - let them pass from an inbound HTTP request straight into the Exchange. In a route that exposes a Lucene query operation behind an HTTP consumer (for example platform-http), any HTTP client could therefore set the QUERY header and have its value executed against the full-text index, overriding the query the route intended to run. Depending on what is indexed, this allows reading documents the request should not have access to (for example a match-all query returns the entire index, or the route's intended per-user filter can be replaced), and expensive regular-expression queries can consume significant CPU. No credentials are required when the HTTP consumer is unauthenticated. This issue affects Apache Camel: from 4.0.0 before 4.14.8, from 4.15.0 before 4.18.3, from 4.19.0 before 4.21.0.

Users are recommended to upgrade to version 4.21.0, which fixes the issue. If users are on the 4.14.x LTS releases stream, then they are suggested to upgrade to 4.14.8. If users are on the 4.18.x releases stream, then they are suggested to upgrade to 4.18.3. After upgrading, routes that set the query via the raw header name must use CamelLuceneQuery (and CamelLuceneReturnLuceneDocs) instead of QUERY / RETURN_LUCENE_DOCS. For deployments that cannot upgrade immediately, strip the attacker-controllable headers before the Lucene producer and set the query from a trusted source (for example removeHeader('QUERY') and removeHeader('RETURN_LUCENE_DOCS'), then setHeader('QUERY', constant(...)) at the start of the route).

Weakness: CWE-639, CWE-20

Which versions are affected by CVE-2026-46585?

6 open source packages ship an affected version, including org.apache.camel:camel-lucene. It affects 1 product.

PackageAffectedFixed in
org.apache.camel:camel-lucene MavenFrom 4.0.04.14.8
org.apache.camel:camel-lucene MavenFrom 4.0.04.14.8
org.apache.camel:camel-lucene MavenFrom 4.15.04.18.3
org.apache.camel:camel-lucene MavenFrom 4.15.04.18.3
org.apache.camel:camel-lucene MavenFrom 4.19.04.21.0
org.apache.camel:camel-lucene MavenFrom 4.19.04.21.0

Products include Apache Camel.

How do I fix CVE-2026-46585?

Upgrade org.apache.camel:camel-lucene to a fixed version for your release line: 4.14.8, 4.18.3 or 4.21.0.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2026-46585 being exploited?

There is no known exploitation of CVE-2026-46585 in the wild and no public exploit code.

Public exploit code: 1 proofs of concept on GitHub.

All Apache Camel vulnerabilities

Sources

Also known as GHSA-566h-v38h-3xp3.

Is CVE-2026-46585 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free