# CVE-2026-46585: Apache Camel-Lucene: The query control headers used non-Camel-prefixed names (QUERY, RETURN_LUCENE_DOCS) that bypass the HTTP header filter, allowing an HTTP client to inject the full-text search query

> Attackers can inject arbitrary Lucene queries via HTTP headers to read unauthorized data or cause denial of service in Apache Camel applications.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Jul 2026
- **Updated:** 6 Jul 2026
- **Also known as:** GHSA-566h-v38h-3xp3

## What is CVE-2026-46585?

CVE-2026-46585 is a high-severity missing authorization vulnerability in Apache Camel, published on 6 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Improper Input Validation, Authorization Bypass Through User-Controlled Key vulnerability in Apache Camel Lucene Component.

The camel-lucene producer reads the search phrase from an Exchange header (LuceneConstants.HEADER_QUERY) whose value was the plain string QUERY (and RETURN_LUCENE_DOCS for HEADER_RETURN_LUCENE_DOCS). Because these names do not start with the Camel / camel prefix, HttpHeaderFilterStrategy - which blocks only the Camel header namespace on the HTTP boundary - let them pass from an inbound HTTP request straight into the Exchange. In a route that exposes a Lucene query operation behind an HTTP consumer (for example platform-http), any HTTP client could therefore set the QUERY header and have its value executed against the full-text index, overriding the query the route intended to run. Depending on what is indexed, this allows reading documents the request should not have access to (for example a match-all query returns the entire index, or the route's intended per-user filter can be replaced), and expensive regular-expression queries can consume significant CPU. No credentials are required when the HTTP consumer is unauthenticated.
This issue affects Apache Camel: from 4.0.0 before 4.14.8, from 4.15.0 before 4.18.3, from 4.19.0 before 4.21.0.

Users are recommended to upgrade to version 4.21.0, which fixes the issue. If users are on the 4.14.x LTS releases stream, then they are suggested to upgrade to 4.14.8. If users are on the 4.18.x releases stream, then they are suggested to upgrade to 4.18.3. After upgrading, routes that set the query via the raw header name must use CamelLuceneQuery (and CamelLuceneReturnLuceneDocs) instead of QUERY / RETURN_LUCENE_DOCS. For deployments that cannot upgrade immediately, strip the attacker-controllable headers before the Lucene producer and set the query from a trusted source (for example removeHeader('QUERY') and removeHeader('RETURN_LUCENE_DOCS'), then setHeader('QUERY', constant(...)) at the start of the route).

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-46585?

6 open source packages ship an affected version, including org.apache.camel:camel-lucene. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.camel:camel-lucene` | Maven | From 4.0.0 | 4.14.8 |
| `org.apache.camel:camel-lucene` | Maven | From 4.0.0 | 4.14.8 |
| `org.apache.camel:camel-lucene` | Maven | From 4.15.0 | 4.18.3 |
| `org.apache.camel:camel-lucene` | Maven | From 4.15.0 | 4.18.3 |
| `org.apache.camel:camel-lucene` | Maven | From 4.19.0 | 4.21.0 |
| `org.apache.camel:camel-lucene` | Maven | From 4.19.0 | 4.21.0 |

Products: Apache Camel.

## How do I fix CVE-2026-46585?

Upgrade org.apache.camel:camel-lucene to a fixed version for your release line: 4.14.8, 4.18.3 or 4.21.0.

## Is CVE-2026-46585 being exploited?

There is no known exploitation of CVE-2026-46585 in the wild and no public exploit code.

Public exploit code:

- Reproducer for CVE-2026-46585: Apache Camel camel-lucene QUERY header injection enabling authorization bypass / index data exfiltration (fixed in 4.14.8/4.18.3/4.21.0) (github_poc): https://github.com/oscerd/CVE-2026-46585

## Other vulnerabilities in Apache Camel

- [CVE-2026-33453](https://insights.sbomify.com/CVE-2026-33453/): Apache camel-coap allows header injection that can lead to remote code execution (critical 10.0)
- [CVE-2026-40453](https://insights.sbomify.com/CVE-2026-40453/): Apache Camel has an incomplete fix for CVE-2025-27636 (critical 9.9)
- [CVE-2026-80351](https://insights.sbomify.com/CVE-2026-80351/): Apache Camel K: Camel K Tenant repositories reach Maven execution inside operator pod (critical 9.8)
- [CVE-2026-80352](https://insights.sbomify.com/CVE-2026-80352/): Apache Camel K: Camel K Master trait serviceAccountName YAML injection lets CR author apply arbitrary objects (critical 9.8)
- [CVE-2026-71300](https://insights.sbomify.com/CVE-2026-71300/): Apache Camel: Camel-Atmosphere-Websocket: WebSocket dispatch header injection (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-46585 and fix it if it is affected.

What it is: CVE-2026-46585 is a high-severity missing authorization vulnerability in Apache Camel, published on 6 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-46585 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.camel:camel-lucene (Maven): affected from 4.0.0; fixed in 4.14.8
- org.apache.camel:camel-lucene (Maven): affected from 4.0.0; fixed in 4.14.8
- org.apache.camel:camel-lucene (Maven): affected from 4.15.0; fixed in 4.18.3
- org.apache.camel:camel-lucene (Maven): affected from 4.15.0; fixed in 4.18.3
- org.apache.camel:camel-lucene (Maven): affected from 4.19.0; fixed in 4.21.0
- org.apache.camel:camel-lucene (Maven): affected from 4.19.0; fixed in 4.21.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-46585/ (Markdown: https://insights.sbomify.com/CVE-2026-46585/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-46585
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-46585
- OSV: https://osv.dev/vulnerability/CVE-2026-46585

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-46585/
Summaries are generated and may contain mistakes; the official description above is the record.
