CVE-2026-46587 Apache Camel-Couchbase: Non-Camel-prefixed Exchange headers bypass HeaderFilterStrategy allowing operation override from untrusted input

High 7.3 Published Updated

Attackers can bypass header filtering in Apache Camel Couchbase components to override operations via untrusted input.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-46587?

CVE-2026-46587 is a high-severity vulnerability in Apache Camel, published on 6 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Improper Input Validation vulnerability in Apache Camel.

This issue affects Apache Camel: through 4.14.7, from 4.15.0 through 4.18.2, from 4.19.0 through 4.20.0.

Users are recommended to upgrade to version 4.14.8, 4.18.3, 4.21.0, which fixes the issue.

Weakness: CWE-20

Which versions are affected by CVE-2026-46587?

6 open source packages ship an affected version, including org.apache.camel:camel-couchbase. It affects 1 product.

PackageAffectedFixed in
org.apache.camel:camel-couchbase MavenFrom 4.0.04.14.8
org.apache.camel:camel-couchbase MavenFrom 4.0.04.14.8
org.apache.camel:camel-couchbase MavenFrom 4.15.04.18.3
org.apache.camel:camel-couchbase MavenFrom 4.15.04.18.3
org.apache.camel:camel-couchbase MavenFrom 4.19.04.21.0
org.apache.camel:camel-couchbase MavenFrom 4.19.04.21.0

Products include Apache Camel.

How do I fix CVE-2026-46587?

Upgrade org.apache.camel:camel-couchbase to a fixed version for your release line: 4.14.8, 4.18.3 or 4.21.0.

Is CVE-2026-46587 being exploited?

There is no known exploitation of CVE-2026-46587 in the wild and no public exploit code.

Public exploit code: 1 proofs of concept on GitHub.

All Apache Camel vulnerabilities

Sources

Also known as GHSA-46jf-c9vx-hh79.

Is CVE-2026-46587 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free