# CVE-2026-4660: Go-getter may allow to arbitrary filesystem reads through git operations

> Attackers can read arbitrary files via malicious URLs in go-getter, impacting applications using this library for git operations.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Apr 2026
- **Updated:** 15 Jul 2026
- **Also known as:** BELL-CVE-2026-4660, CLEANSTART-2026-KS06935, CLEANSTART-2026-MS09859, DEBIAN-CVE-2026-4660, GHSA-92mm-2pjq-r785, GO-2026-5058, MINI-228w-5pjh-rpf3, MINI-2qm8-mw3h-5vh6, MINI-32v7-9xfc-cww2, MINI-356c-wvxq-q87v, MINI-44m8-q7vj-r7j7, MINI-4624-8hpg-rcj5, MINI-49cx-j3r2-r26m, MINI-4qhh-466x-cjcq, MINI-4vh4-c8fv-rh97, MINI-555x-v2x6-ww59, MINI-59fg-jpw8-j49h, MINI-5c46-qc6j-chmr, MINI-5q5f-gvmc-23r6, MINI-6hx6-pc84-hmcx, MINI-6j4j-9gj2-pqxc, MINI-6m27-4vmx-gwfx, MINI-7263-f7rp-hmv4, MINI-7343-5rf6-58c2, MINI-77q7-qp5r-8x5j, MINI-7hfr-mgrm-rvwr, MINI-88cq-jjwh-w3cq, MINI-8fxc-p5q8-759x, MINI-93vf-2w7h-3m9g, MINI-96p2-5vfh-93rq, MINI-98vv-6rw2-jh2p, MINI-9v6q-jfvj-cppg, MINI-c929-w75p-2w88, MINI-cxvr-wccp-5wwp, MINI-f2v9-8j75-pvpx, MINI-fcm2-ghx5-92gh, MINI-h32w-p463-8m6q, MINI-hhcr-pr5j-7rvq, MINI-hhq4-c57w-g356, MINI-m2vf-5jwp-7325, MINI-m3p5-vm28-jmr7, MINI-mrv7-3h6j-mhv8, MINI-mv8p-575x-25px, MINI-ph9g-54gm-f6wh, MINI-pj26-3243-358v, MINI-pqrj-r9p9-cwpm, MINI-q325-phc5-64jf, MINI-q7mm-8jmg-gffg, MINI-qf82-x8q2-j9h4, MINI-qrjx-p53h-96wr, MINI-rv5j-g8j3-j8c9, MINI-v9qp-g62x-5gmm, MINI-vc6w-w629-992r, MINI-vh6q-6fmh-fpg2, MINI-vvv7-wh56-7p8p, MINI-x9vm-rfc6-pr5x, ROOT-APP-GOBINARY-CVE-2026-4660, UBUNTU-CVE-2026-4660

## What is CVE-2026-4660?

CVE-2026-4660 is a high-severity path traversal vulnerability in HashiCorp Tooling, published on 9 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

HashiCorp’s go-getter library up to v1.8.5 may allow arbitrary file reads on the file system during certain git operations through a maliciously crafted URL. This vulnerability, CVE-2026-4660, is fixed in go-getter v1.8.6. This vulnerability does not affect the go-getter/v2 branch and package.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-4660?

3 open source packages ship an affected version, including github.com/hashicorp/go-getter.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/hashicorp/go-getter` | Go | All versions | 1.8.6 |
| `github.com/hashicorp/go-getter` | Go | All versions | 1.8.6 |
| `github.com/hashicorp/go-getter` | Go | All versions | 1.8.6 |

## How do I fix CVE-2026-4660?

Upgrade github.com/hashicorp/go-getter to 1.8.6 or later.

## Is CVE-2026-4660 being exploited?

There is no known exploitation of CVE-2026-4660 in the wild and no public exploit code.

Public exploit code:

- PoC for CVE-2026-4660: arbitrary file read via git checkout in hashicorp/go-getter (github_poc): https://github.com/gouldnicholas/CVE-2026-4660-PoC

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-4660 and fix it if it is affected.

What it is: CVE-2026-4660 is a high-severity path traversal vulnerability in HashiCorp Tooling, published on 9 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-4660 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/hashicorp/go-getter (Go): affected all versions; fixed in 1.8.6
- github.com/hashicorp/go-getter (Go): affected all versions; fixed in 1.8.6
- github.com/hashicorp/go-getter (Go): affected all versions; fixed in 1.8.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-4660/ (Markdown: https://insights.sbomify.com/CVE-2026-4660/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-4660
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-4660
- OSV: https://osv.dev/vulnerability/CVE-2026-4660

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-4660/
Summaries are generated and may contain mistakes; the official description above is the record.
