# CVE-2026-46605: Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ: Incomplete authorization during destination removal

> Authenticated users can improperly remove existing destinations due to incomplete authorization checks in Apache ActiveMQ.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Jun 2026
- **Updated:** 1 Jun 2026
- **Also known as:** BIT-activemq-2026-46605, DEBIAN-CVE-2026-46605, GHSA-cpw7-g3p5-qrfq, MINI-32xg-ffpj-2j2g, MINI-9r62-p5xr-888m, MINI-gh74-r2cv-7h2r, MINI-m4f5-f4q7-vf35, UBUNTU-CVE-2026-46605

## What is CVE-2026-46605?

CVE-2026-46605 is a medium-severity missing authorization vulnerability in Apache Activemq, published on 1 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Incomplete authorization by Apache ActiveMQ server before versions v6.2.6 and v5.19.7 allows authenticated connections to remove existing destinations with proper permissions.

This issue affects Apache ActiveMQ Broker: before 5.19.7, from 6.0.0 before 6.2.6; Apache ActiveMQ All: before 5.19.7, from 6.0.0 before 6.2.6; Apache ActiveMQ: before 5.19.7, from 6.0.0 before 6.2.6.

Users are recommended to upgrade to version v6.2.6 or v5.19.7, which fixes the issue.

Weakness: CWE-285 (Improper Authorization)

## Which versions are affected by CVE-2026-46605?

5 open source packages ship an affected version, including org.apache.activemq:apache-activemq and activemq. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.activemq:apache-activemq` | Maven | All versions | 5.19.7 |
| `org.apache.activemq:apache-activemq` | Maven | All versions | 5.19.7 |
| `org.apache.activemq:apache-activemq` | Maven | From 6.0.0 | 6.2.6 |
| `org.apache.activemq:apache-activemq` | Maven | From 6.0.0 | 6.2.6 |
| `activemq` | Bitnami | All versions | 5.19.7, 6.2.6 |

Products: Apache Activemq, Apache Activemq Broker.

## How do I fix CVE-2026-46605?

Upgrade org.apache.activemq:apache-activemq to a fixed version for your release line: 5.19.7 or 6.2.6.

## Is CVE-2026-46605 being exploited?

There is no known exploitation of CVE-2026-46605 in the wild and no public exploit code.

## Other vulnerabilities in Apache Activemq

- [CVE-2023-46604](https://insights.sbomify.com/CVE-2023-46604/): Apache ActiveMQ Deserialization of Untrusted Data (critical 10.0, exploited in the wild)
- [CVE-2016-3088](https://insights.sbomify.com/CVE-2016-3088/): Apache ActiveMQ Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2026-34197](https://insights.sbomify.com/CVE-2026-34197/): Apache ActiveMQ Improper Input Validation (high 8.8, exploited in the wild)
- [CVE-2020-11998](https://insights.sbomify.com/CVE-2020-11998/): Remote code execution in Apache ActiveMQ (critical 9.8)
- [CVE-2013-7285](https://insights.sbomify.com/CVE-2013-7285/): Command Injection in Xstream (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-46605 and fix it if it is affected.

What it is: CVE-2026-46605 is a medium-severity missing authorization vulnerability in Apache Activemq, published on 1 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-46605 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.activemq:apache-activemq (Maven): affected all versions; fixed in 5.19.7
- org.apache.activemq:apache-activemq (Maven): affected all versions; fixed in 5.19.7
- org.apache.activemq:apache-activemq (Maven): affected from 6.0.0; fixed in 6.2.6
- org.apache.activemq:apache-activemq (Maven): affected from 6.0.0; fixed in 6.2.6
- activemq (Bitnami): affected all versions; fixed in 5.19.7, 6.2.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-46605/ (Markdown: https://insights.sbomify.com/CVE-2026-46605/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-46605
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-46605
- OSV: https://osv.dev/vulnerability/CVE-2026-46605

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-46605/
Summaries are generated and may contain mistakes; the official description above is the record.
