{"answers":{"affected":"3 open source packages ship an affected version, including glances.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-46606 exists.","fix":"Upgrade glances to 4.5.5 or later.","what":"CVE-2026-46606 is a high-severity command injection vulnerability in nicolargo glances, published on 25 Jun 2026. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-46606 and fix it if it is affected.\n\nWhat it is: CVE-2026-46606 is a high-severity command injection vulnerability in nicolargo glances, published on 25 Jun 2026. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-46606 exists.\n\nAffected packages and fixed versions:\n- glances (PyPI): affected all versions; fixed in 4.5.5\n- glances (PyPI): affected all versions; fixed in 4.5.5\n- glances (PyPI): affected all versions; fixed in 4.5.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-46606/ (Markdown: https://insights.sbomify.com/CVE-2026-46606/index.md)","id":"CVE-2026-46606","markdown":"https://insights.sbomify.com/CVE-2026-46606/index.md","name":"CVE-2026-46606","record":{"aliases":["DEBIAN-CVE-2026-46606","GHSA-v5r2-qh84-fjx5","PYSEC-2026-2497","UBUNTU-CVE-2026-46606"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution","privilege_escalation"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"System monitoring tool","requires_auth":"low_privilege","summary":"Attackers can execute arbitrary commands as root by crafting malicious KVM/QEMU VM domain names in Glances monitoring tool.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"}],"description":"Glances is an open-source system cross-platform monitoring tool. Prior to 4.5.5, the Glances KVM/QEMU monitoring engine (glances/plugins/vms/engines/virsh.py) passes VM domain names, read directly from virsh list --all output, into f-string command templates that are processed by secure_popen(). secure_popen() is explicitly designed to interpret \u0026\u0026, |, and \u003e as shell operators. Because domain names are never sanitised before interpolation, any user with the ability to create or rename a KVM/QEMU virtual machine can execute arbitrary commands as the OS user running Glances — commonly root on hypervisor hosts. This vulnerability is fixed in 4.5.5.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Glances: Command Injection via KVM/QEMU VM Domain Names in glances/plugins/vms/engines/virsh.py","id":"CVE-2026-46606","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"command_injection","year":"2026"},"n_packages":3,"n_references":2,"next":{"headline":"Glances: Insecure Pickle Deserialization in Version Cache Leads to Arbitrary Code Execution","id":"CVE-2026-46607"},"packages":[{"ecosystem":"PyPI","fixed":["4.5.5"],"introduced":["0"],"last_affected":[],"package":"glances","purl":null,"source":"GHSA-v5r2-qh84-fjx5"},{"ecosystem":"PyPI","fixed":["4.5.5"],"introduced":["0"],"last_affected":[],"package":"glances","purl":"pkg:pypi/glances","source":"GHSA-v5r2-qh84-fjx5"},{"ecosystem":"PyPI","fixed":["4.5.5"],"introduced":["0"],"last_affected":[],"package":"glances","purl":"pkg:pypi/glances","source":"PYSEC-2026-2497"}],"prev":{"headline":"Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ: Incomplete authorization during destination removal","id":"CVE-2026-46605"},"products":["glances"],"published":"2026-06-25","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-06-25","vendors":["nicolargo"]},"summary":"Attackers can execute arbitrary commands as root by crafting malicious KVM/QEMU VM domain names in Glances monitoring tool.","url":"https://insights.sbomify.com/CVE-2026-46606/"}