# CVE-2026-46606: Glances: Command Injection via KVM/QEMU VM Domain Names in glances/plugins/vms/engines/virsh.py

> Attackers can execute arbitrary commands as root by crafting malicious KVM/QEMU VM domain names in Glances monitoring tool.

- **Severity:** High 7.8 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Jun 2026
- **Updated:** 25 Jun 2026
- **Also known as:** DEBIAN-CVE-2026-46606, GHSA-v5r2-qh84-fjx5, PYSEC-2026-2497, UBUNTU-CVE-2026-46606

## What is CVE-2026-46606?

CVE-2026-46606 is a high-severity command injection vulnerability in nicolargo glances, published on 25 Jun 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Glances is an open-source system cross-platform monitoring tool. Prior to 4.5.5, the Glances KVM/QEMU monitoring engine (glances/plugins/vms/engines/virsh.py) passes VM domain names, read directly from virsh list --all output, into f-string command templates that are processed by secure_popen(). secure_popen() is explicitly designed to interpret &&, |, and > as shell operators. Because domain names are never sanitised before interpolation, any user with the ability to create or rename a KVM/QEMU virtual machine can execute arbitrary commands as the OS user running Glances — commonly root on hypervisor hosts. This vulnerability is fixed in 4.5.5.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2026-46606?

3 open source packages ship an affected version, including glances.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `glances` | PyPI | All versions | 4.5.5 |
| `glances` | PyPI | All versions | 4.5.5 |
| `glances` | PyPI | All versions | 4.5.5 |

## How do I fix CVE-2026-46606?

Upgrade glances to 4.5.5 or later.

## Is CVE-2026-46606 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-46606 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-46606 and fix it if it is affected.

What it is: CVE-2026-46606 is a high-severity command injection vulnerability in nicolargo glances, published on 25 Jun 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-46606 exists.

Affected packages and fixed versions:
- glances (PyPI): affected all versions; fixed in 4.5.5
- glances (PyPI): affected all versions; fixed in 4.5.5
- glances (PyPI): affected all versions; fixed in 4.5.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-46606/ (Markdown: https://insights.sbomify.com/CVE-2026-46606/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-46606
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-46606
- OSV: https://osv.dev/vulnerability/CVE-2026-46606

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-46606/
Summaries are generated and may contain mistakes; the official description above is the record.
