# CVE-2026-46608: Glances: XML-RPC Multi-Origin CORS Configuration Silently Falls Back to Wildcard (Incomplete Fix for CVE-2026-33533)

> Glances XML-RPC server incorrectly applies wildcard CORS when multiple origins are configured, allowing malicious sites to read system monitoring data.

- **Severity:** High 7.4 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 25 Jun 2026
- **Updated:** 26 Jun 2026
- **Also known as:** DEBIAN-CVE-2026-46608, GHSA-87qc-fj39-wccr, PYSEC-2026-2495, UBUNTU-CVE-2026-46608

## What is CVE-2026-46608?

CVE-2026-46608 is a high-severity vulnerability in nicolargo glances, published on 25 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Glances is an open-source system cross-platform monitoring tool. Prior to 4.5.5, the Glances XML-RPC server (glances -s) introduced a configurable CORS origin list in version 4.5.3 as a mitigation for CVE-2026-33533. However, the implementation silently falls back to Access-Control-Allow-Origin: * whenever cors_origins contains more than one entry. An operator who configures an explicit two-entry allowlist (e.g. two internal dashboard origins) intending to restrict browser access instead receives the unrestricted wildcard. A malicious web page served from any origin can issue a CORS simple request to /RPC2 and read the full system monitoring dataset without the victim's knowledge. This vulnerability is fixed in 4.5.5.

Weakness: CWE-942 (Permissive Cross-domain Security Policy with Untrusted Domains), CWE-183 (Permissive List of Allowed Inputs)

## Which versions are affected by CVE-2026-46608?

3 open source packages ship an affected version, including glances.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `glances` | PyPI | All versions | 4.5.5 |
| `glances` | PyPI | All versions | 4.5.5 |
| `glances` | PyPI | All versions | 4.5.5 |

## How do I fix CVE-2026-46608?

Upgrade glances to 4.5.5 or later.

## Is CVE-2026-46608 being exploited?

There is no known exploitation of CVE-2026-46608 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-46608 and fix it if it is affected.

What it is: CVE-2026-46608 is a high-severity vulnerability in nicolargo glances, published on 25 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-46608 in the wild and no public exploit code.

Affected packages and fixed versions:
- glances (PyPI): affected all versions; fixed in 4.5.5
- glances (PyPI): affected all versions; fixed in 4.5.5
- glances (PyPI): affected all versions; fixed in 4.5.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-46608/ (Markdown: https://insights.sbomify.com/CVE-2026-46608/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-46608
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-46608
- OSV: https://osv.dev/vulnerability/CVE-2026-46608

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-46608/
Summaries are generated and may contain mistakes; the official description above is the record.
