# CVE-2026-46620: e107: CSRF in comment.php moderation endpoints via token-optional validation in session_handler::check()

> Attackers can bypass CSRF protection on comment moderation endpoints in e107 CMS, potentially performing unauthorized actions.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 26 May 2026
- **Updated:** 27 May 2026
- **Also known as:** GHSA-m4hh-m278-jwg5

## What is CVE-2026-46620?

CVE-2026-46620 is a medium-severity vulnerability in e107inc e107, published on 26 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

e107 is a content management system (CMS). Prior to 2.3.5, e107 CMS does not properly enforce CSRF token validation on comment moderation actions. The problem comes down to how session_handler::check() handles CSRF tokens. Instead of requiring a token on every state-changing request, it only validates the token if one happens to be present. If there is no token at all, the check is skipped entirely. This vulnerability is fixed in 2.3.5.

Weakness: CWE-352 (Cross-Site Request Forgery), CWE-285 (Improper Authorization)

## Which versions are affected by CVE-2026-46620?


## How do I fix CVE-2026-46620?

No fix has been published for CVE-2026-46620 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-46620 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-46620 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-46620 and fix it if it is affected.

What it is: CVE-2026-46620 is a medium-severity vulnerability in e107inc e107, published on 26 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-46620 exists.

Affected product: e107inc e107. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-46620/ (Markdown: https://insights.sbomify.com/CVE-2026-46620/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-46620
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-46620
- OSV: https://osv.dev/vulnerability/CVE-2026-46620

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-46620/
Summaries are generated and may contain mistakes; the official description above is the record.
