# CVE-2026-46637: Twig: HTML-output filters in twig/* extras incorrectly declared `is_safe => ['all']`

> Attackers can inject malicious scripts via Twig markdown or CSS inliner filters due to incorrect safe output declarations, leading to XSS.

- **Severity:** Medium 5.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 14 Jul 2026
- **Updated:** 16 Jul 2026
- **Also known as:** DEBIAN-CVE-2026-46637, GHSA-jv8m-2544-3pg3, UBUNTU-CVE-2026-46637

## What is CVE-2026-46637?

CVE-2026-46637 is a medium-severity cross-site scripting vulnerability in Twig, published on 14 Jul 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Twig is a template language for PHP. Prior to 3.26.0, several filters in twig/markdown-extra and twig/cssinliner-extra are registered with is_safe => [all], causing Twig to treat plain text or HTML output as safe in HTML, JavaScript, CSS, URL, and other contexts where the output is not properly escaped. This issue is fixed in version 3.26.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-116 (Improper Encoding or Escaping of Output)

## Which versions are affected by CVE-2026-46637?

4 open source packages ship an affected version, including twig/cssinliner-extra and twig/markdown-extra. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `twig/cssinliner-extra` | Packagist | All versions | 3.26.0 |
| `twig/cssinliner-extra` | Packagist | All versions | 3.26.0 |
| `twig/markdown-extra` | Packagist | All versions | 3.26.0 |
| `twig/markdown-extra` | Packagist | All versions | 3.26.0 |

Products: Symfony Twig.

## How do I fix CVE-2026-46637?

Upgrade twig/cssinliner-extra to 3.26.0 or later.

## Is CVE-2026-46637 being exploited?

There is no known exploitation of CVE-2026-46637 in the wild and no public exploit code.

## Other vulnerabilities in Twig

- [CVE-2018-13818](https://insights.sbomify.com/CVE-2018-13818/): Code injection in n/a (critical 9.8)
- [CVE-2026-46633](https://insights.sbomify.com/CVE-2026-46633/): Twig: PHP code injection via `{% use %}` template name (high 8.7)
- [CVE-2026-46640](https://insights.sbomify.com/CVE-2026-46640/): Twig: Arbitrary PHP code execution via `_self.(<string>)` macro-reference compilation (high 8.7)
- [CVE-2026-24425](https://insights.sbomify.com/CVE-2026-24425/): Twig 2.16.x & 3.9.0-3.25.x Sandbox Bypass via SourcePolicyInterface (high 8.7)
- [CVE-2024-45411](https://insights.sbomify.com/CVE-2024-45411/): Twig has a possible sandbox bypass (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-46637 and fix it if it is affected.

What it is: CVE-2026-46637 is a medium-severity cross-site scripting vulnerability in Twig, published on 14 Jul 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-46637 in the wild and no public exploit code.

Affected packages and fixed versions:
- twig/cssinliner-extra (Packagist): affected all versions; fixed in 3.26.0
- twig/cssinliner-extra (Packagist): affected all versions; fixed in 3.26.0
- twig/markdown-extra (Packagist): affected all versions; fixed in 3.26.0
- twig/markdown-extra (Packagist): affected all versions; fixed in 3.26.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-46637/ (Markdown: https://insights.sbomify.com/CVE-2026-46637/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-46637
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-46637
- OSV: https://osv.dev/vulnerability/CVE-2026-46637

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-46637/
Summaries are generated and may contain mistakes; the official description above is the record.
