CVE-2026-46638 Twig: `{% sandbox %}{% include %}` skips checkSecurity() on cached templates (incomplete fix for CVE-2024-45411)
Attackers can bypass Twig sandbox security policies by exploiting cached templates, allowing execution of restricted tags and functions.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-46638?
CVE-2026-46638 is a medium-severity vulnerability in twigphp Twig, published on 14 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Twig is a template language for PHP. Prior to 3.26.0, {% sandbox %}{% include %} can include a template that was previously loaded outside the sandbox without re-invoking checkSecurity(), allowing the cached template to use tags, filters, and functions that should have been denied by SecurityPolicy::checkSecurity(). This issue is fixed in version 3.26.0.
Weakness: CWE-693
Which versions are affected by CVE-2026-46638?
2 open source packages ship an affected version, including twig/twig. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
twig/twig Packagist | All versions | 3.26.0 |
twig/twig Packagist | All versions | 3.26.0 |
Products include Symfony Twig.
How do I fix CVE-2026-46638?
Upgrade twig/twig to 3.26.0 or later.
Is CVE-2026-46638 being exploited?
There is no known exploitation of CVE-2026-46638 in the wild and no public exploit code.
Other vulnerabilities in twigphp Twig
- CVE-2018-13818 Code injection in n/a
- CVE-2026-46633 Twig: PHP code injection via `{% use %}` template name
- CVE-2026-46640 Twig: Arbitrary PHP code execution via `_self.(<string>)` macro-reference compilation
- CVE-2026-24425 Twig 2.16.x & 3.9.0-3.25.x Sandbox Bypass via SourcePolicyInterface
- CVE-2024-45411 Twig has a possible sandbox bypass
Sources
Also known as DEBIAN-CVE-2026-46638, GHSA-7fxw-r6jv-74c8, ROOT-APP-COMPOSER-CVE-2026-46638, UBUNTU-CVE-2026-46638.