CVE-2026-46644 symfony/polyfill-intl-idn accepts xn-- labels whose Punycode payload decodes to ASCII-only: insecure equivalence

Medium 6.9 Published Updated
Exploited in the wild
Not known
Fix
Available

What is CVE-2026-46644?

CVE-2026-46644 is a medium-severity vulnerability in symfony polyfill, published on 14 Jul 2026.

Official description

Symfony Polyfill backports PHP features and provides compatibility layers for extensions and functions. From 1.17.1 until 1.38.1, symfony/polyfill-intl-idn accepts xn-- labels whose Punycode payload is empty or decodes to ASCII-only code points because Idn::process() does not enforce the UTS #46 revision 33 requirement that decoded ACE labels contain at least one non-ASCII code point. Originally unequal domain names can be regarded as equal, which can lead to blacklist bypassing, inconsistent URL parsing, and server-side request forgery in applications using the polyfill to canonicalise or compare hostnames. This issue is fixed in version 1.38.1.

Weakness: CWE-1289

Which versions are affected by CVE-2026-46644?

4 open source packages ship an affected version, including symfony/polyfill and symfony/polyfill-intl-idn.

PackageAffectedFixed in
symfony/polyfill PackagistFrom 1.17.11.38.1
symfony/polyfill PackagistFrom 1.17.11.38.1
symfony/polyfill-intl-idn PackagistFrom 1.17.11.38.1
symfony/polyfill-intl-idn PackagistFrom 1.17.11.38.1

How do I fix CVE-2026-46644?

Upgrade symfony/polyfill to 1.38.1 or later.

Is CVE-2026-46644 being exploited?

There is no known exploitation of CVE-2026-46644 in the wild and no public exploit code.

Sources

Also known as CLSA-2026-1788334122, DEBIAN-CVE-2026-46644, GHSA-2xf4-cg6j-vhgq, UBUNTU-CVE-2026-46644.

Is CVE-2026-46644 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free