{"answers":{"affected":"4 open source packages ship an affected version, including symfony/polyfill and symfony/polyfill-intl-idn.","exploited":"There is no known exploitation of CVE-2026-46644 in the wild and no public exploit code.","fix":"Upgrade symfony/polyfill to 1.38.1 or later.","what":"CVE-2026-46644 is a medium-severity vulnerability in symfony polyfill, published on 14 Jul 2026."},"fix_prompt":"Check this codebase for CVE-2026-46644 and fix it if it is affected.\n\nWhat it is: CVE-2026-46644 is a medium-severity vulnerability in symfony polyfill, published on 14 Jul 2026. \nExploitation: There is no known exploitation of CVE-2026-46644 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- symfony/polyfill (Packagist): affected from 1.17.1; fixed in 1.38.1\n- symfony/polyfill (Packagist): affected from 1.17.1; fixed in 1.38.1\n- symfony/polyfill-intl-idn (Packagist): affected from 1.17.1; fixed in 1.38.1\n- symfony/polyfill-intl-idn (Packagist): affected from 1.17.1; fixed in 1.38.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-46644/ (Markdown: https://insights.sbomify.com/CVE-2026-46644/index.md)","id":"CVE-2026-46644","markdown":"https://insights.sbomify.com/CVE-2026-46644/index.md","name":"CVE-2026-46644","record":{"aliases":["CLSA-2026-1788334122","DEBIAN-CVE-2026-46644","GHSA-2xf4-cg6j-vhgq","UBUNTU-CVE-2026-46644"],"analysis":null,"analysis_generated_by":null,"assigner":"GitHub_M","cpe":[],"cvss":{"score":6.9,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:L/SI:L/SA:N","version":"4.0"},"cwes":[{"id":"CWE-1289","name":"Improper Validation of Unsafe Equivalence in Input"}],"description":"Symfony Polyfill backports PHP features and provides compatibility layers for extensions and functions. From 1.17.1 until 1.38.1, symfony/polyfill-intl-idn accepts xn-- labels whose Punycode payload is empty or decodes to ASCII-only code points because Idn::process() does not enforce the UTS #46 revision 33 requirement that decoded ACE labels contain at least one non-ASCII code point. Originally unequal domain names can be regarded as equal, which can lead to blacklist bypassing, inconsistent URL parsing, and server-side request forgery in applications using the polyfill to canonicalise or compare hostnames. This issue is fixed in version 1.38.1.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"symfony/polyfill-intl-idn accepts xn-- labels whose Punycode payload decodes to ASCII-only: insecure equivalence","id":"CVE-2026-46644","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":null,"year":"2026"},"n_packages":4,"n_references":3,"next":{"headline":"SQLAdmin: Authorization Bypass on `ajax_lookup`","id":"CVE-2026-46645"},"packages":[{"ecosystem":"Packagist","fixed":["1.38.1"],"introduced":["1.17.1"],"last_affected":[],"package":"symfony/polyfill","purl":null,"source":"GHSA-2xf4-cg6j-vhgq"},{"ecosystem":"Packagist","fixed":["1.38.1"],"introduced":["1.17.1"],"last_affected":[],"package":"symfony/polyfill","purl":"pkg:composer/symfony/polyfill","source":"GHSA-2xf4-cg6j-vhgq"},{"ecosystem":"Packagist","fixed":["1.38.1"],"introduced":["1.17.1"],"last_affected":[],"package":"symfony/polyfill-intl-idn","purl":null,"source":"GHSA-2xf4-cg6j-vhgq"},{"ecosystem":"Packagist","fixed":["1.38.1"],"introduced":["1.17.1"],"last_affected":[],"package":"symfony/polyfill-intl-idn","purl":"pkg:composer/symfony/polyfill-intl-idn","source":"GHSA-2xf4-cg6j-vhgq"}],"prev":{"headline":"Snappy: Binary path is never shell-escaped due to an inverted is_executable check","id":"CVE-2026-46643"},"products":["polyfill","polyfill-intl-idn"],"published":"2026-07-14","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-07-15","vendors":["symfony"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2026-46644/"}