# CVE-2026-46644: symfony/polyfill-intl-idn accepts xn-- labels whose Punycode payload decodes to ASCII-only: insecure equivalence


- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 14 Jul 2026
- **Updated:** 15 Jul 2026
- **Also known as:** CLSA-2026-1788334122, DEBIAN-CVE-2026-46644, GHSA-2xf4-cg6j-vhgq, UBUNTU-CVE-2026-46644

## What is CVE-2026-46644?

CVE-2026-46644 is a medium-severity vulnerability in symfony polyfill, published on 14 Jul 2026. 

### Official description

Symfony Polyfill backports PHP features and provides compatibility layers for extensions and functions. From 1.17.1 until 1.38.1, symfony/polyfill-intl-idn accepts xn-- labels whose Punycode payload is empty or decodes to ASCII-only code points because Idn::process() does not enforce the UTS #46 revision 33 requirement that decoded ACE labels contain at least one non-ASCII code point. Originally unequal domain names can be regarded as equal, which can lead to blacklist bypassing, inconsistent URL parsing, and server-side request forgery in applications using the polyfill to canonicalise or compare hostnames. This issue is fixed in version 1.38.1.

Weakness: CWE-1289 (Improper Validation of Unsafe Equivalence in Input)

## Which versions are affected by CVE-2026-46644?

4 open source packages ship an affected version, including symfony/polyfill and symfony/polyfill-intl-idn.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `symfony/polyfill` | Packagist | From 1.17.1 | 1.38.1 |
| `symfony/polyfill` | Packagist | From 1.17.1 | 1.38.1 |
| `symfony/polyfill-intl-idn` | Packagist | From 1.17.1 | 1.38.1 |
| `symfony/polyfill-intl-idn` | Packagist | From 1.17.1 | 1.38.1 |

## How do I fix CVE-2026-46644?

Upgrade symfony/polyfill to 1.38.1 or later.

## Is CVE-2026-46644 being exploited?

There is no known exploitation of CVE-2026-46644 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-46644 and fix it if it is affected.

What it is: CVE-2026-46644 is a medium-severity vulnerability in symfony polyfill, published on 14 Jul 2026. 
Exploitation: There is no known exploitation of CVE-2026-46644 in the wild and no public exploit code.

Affected packages and fixed versions:
- symfony/polyfill (Packagist): affected from 1.17.1; fixed in 1.38.1
- symfony/polyfill (Packagist): affected from 1.17.1; fixed in 1.38.1
- symfony/polyfill-intl-idn (Packagist): affected from 1.17.1; fixed in 1.38.1
- symfony/polyfill-intl-idn (Packagist): affected from 1.17.1; fixed in 1.38.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-46644/ (Markdown: https://insights.sbomify.com/CVE-2026-46644/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-46644
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-46644
- OSV: https://osv.dev/vulnerability/CVE-2026-46644

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-46644/
Summaries are generated and may contain mistakes; the official description above is the record.
