# CVE-2026-46654: Plonky3 MultiField32Challenger: transcript malleability and challenge entropy loss

> An attacker can craft distinct transcripts producing identical challenges, breaking Fiat-Shamir binding in Plonky3 polynomial IOPs.

- **Severity:** High 8.9 (`CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:H/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Jun 2026
- **Updated:** 11 Jun 2026
- **Also known as:** GHSA-vj64-rjf3-w3v7

## What is CVE-2026-46654?

CVE-2026-46654 is a high-severity vulnerability in Plonky3, published on 10 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Plonky3 is a toolkit for polynomial IOPs (PIOPs). Prior to versions 0.4.3 and 0.5.3, an attacker controlling prover-side observations can craft distinct transcripts that produce identical challenges, breaking the binding property of Fiat-Shamir. This issue has been patched in versions 0.4.3 and 0.5.3.

Weakness: CWE-345 (Insufficient Verification of Data Authenticity), CWE-1240 (Use of a Cryptographic Primitive with a Risky Implementation)

## Which versions are affected by CVE-2026-46654?

4 open source packages ship an affected version, including p3-challenger.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `p3-challenger` | crates.io | All versions | 0.4.3 |
| `p3-challenger` | crates.io | All versions | 0.4.3 |
| `p3-challenger` | crates.io | From 0.5.0 | 0.5.3 |
| `p3-challenger` | crates.io | From 0.5.0 | 0.5.3 |

## How do I fix CVE-2026-46654?

Upgrade p3-challenger to a fixed version for your release line: 0.4.3 or 0.5.3.

## Is CVE-2026-46654 being exploited?

There is no known exploitation of CVE-2026-46654 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-46654 and fix it if it is affected.

What it is: CVE-2026-46654 is a high-severity vulnerability in Plonky3, published on 10 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-46654 in the wild and no public exploit code.

Affected packages and fixed versions:
- p3-challenger (crates.io): affected all versions; fixed in 0.4.3
- p3-challenger (crates.io): affected all versions; fixed in 0.4.3
- p3-challenger (crates.io): affected from 0.5.0; fixed in 0.5.3
- p3-challenger (crates.io): affected from 0.5.0; fixed in 0.5.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-46654/ (Markdown: https://insights.sbomify.com/CVE-2026-46654/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-46654
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-46654
- OSV: https://osv.dev/vulnerability/CVE-2026-46654

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-46654/
Summaries are generated and may contain mistakes; the official description above is the record.
