# CVE-2026-46670: YesWiki: Unauthenticated SQL Injection

> Unauthenticated attackers can inject SQL into YesWiki to read the full database, including user password hashes.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Aug 2026
- **Updated:** 13 Aug 2026
- **Also known as:** GHSA-jwvv-qr7q-cv8j

## What is CVE-2026-46670?

CVE-2026-46670 is a critical SQL injection vulnerability in yeswiki, published on 11 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

YesWiki is a wiki system written in PHP. Prior to version 4.6.4,  an unauthenticated SQL injection in the Bazar form-import path (`FormManager::create()`) allows any unauthenticated visitor of a default YesWiki install to inject arbitrary SQL into an `INSERT` statement and read the full database, including `yeswiki_users.password` hashes. Version 4.6.4 fixes the issue.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2026-46670?

2 open source packages ship an affected version, including yeswiki/yeswiki.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `yeswiki/yeswiki` | Packagist | All versions | 4.6.4 |
| `yeswiki/yeswiki` | Packagist | All versions | 4.6.4 |

## How do I fix CVE-2026-46670?

Upgrade yeswiki/yeswiki to 4.6.4 or later.

## Is CVE-2026-46670 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-46670 exists.

Public exploit code:

- YesWiki < 4.6.4 - Unauthenticated SQL Injection (nuclei): http/cves/2026/CVE-2026-46670.yaml

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-46670 and fix it if it is affected.

What it is: CVE-2026-46670 is a critical SQL injection vulnerability in yeswiki, published on 11 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-46670 exists.

Affected packages and fixed versions:
- yeswiki/yeswiki (Packagist): affected all versions; fixed in 4.6.4
- yeswiki/yeswiki (Packagist): affected all versions; fixed in 4.6.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-46670/ (Markdown: https://insights.sbomify.com/CVE-2026-46670/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-46670
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-46670
- OSV: https://osv.dev/vulnerability/CVE-2026-46670

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-46670/
Summaries are generated and may contain mistakes; the official description above is the record.
