CVE-2026-46680 containerd user ID handling bypass allows runAsNonRoot evasion
Attackers can bypass Kubernetes runAsNonRoot restrictions by crafting images with specific numeric user IDs, causing containers to run as root.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Local or same network only
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-46680?
CVE-2026-46680 is a high-severity vulnerability in containerd, published on 1 Jul 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Official description
containerd is an open-source container runtime. In versions prior to 1.7.32, 2.0.9, 2.2.4 and 2.3.1, containers launched with a numeric User directive that cannot be parsed as a 32-bit integer are incorrectly treated as a username, leading to runAsNonRoot evasion. If a crafted image provides an /etc/passwd file mapping this large numeric string to root, the container ultimately runs as root (UID 0). This allows the Kubernetes runAsNonRoot restriction to be bypassed, causing unexpected behavior for environments that require containers to run as a non-root user. This issue has been fixed in versions 1.7.32, 2.0.9, 2.2.4 and 2.3.1.
Weakness: CWE-269
Which versions are affected by CVE-2026-46680?
10 open source packages ship an affected version, including github.com/containerd/containerd/v2 and github.com/containerd/containerd. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/containerd/containerd/v2 Go | From 2.0.4 | 2.0.9, 2.2.4, 2.3.1 |
github.com/containerd/containerd/v2 Go | From 2.0.4 | 2.0.9 |
github.com/containerd/containerd/v2 Go | From 2.0.4 | 2.0.9 |
github.com/containerd/containerd/v2 Go | From 2.1.0-beta.0 | 2.2.4 |
github.com/containerd/containerd/v2 Go | From 2.1.0-beta.0 | 2.2.4 |
github.com/containerd/containerd/v2 Go | From 2.3.0-beta.0 | 2.3.1 |
4 more packages
github.com/containerd/containerd/v2 Go | From 2.3.0-beta.0 | 2.3.1 |
github.com/containerd/containerd Go | From 1.7.27 | 1.7.32 |
github.com/containerd/containerd Go | From 1.7.27 | 1.7.32 |
github.com/containerd/containerd Go | From 1.7.27 | 1.7.32 |
Linux distribution packages (1)
trivy openSUSE:Tumbleweed | All versions | 0.71.1-2.1 |
Products include Linuxfoundation Containerd.
How do I fix CVE-2026-46680?
Upgrade github.com/containerd/containerd/v2 to a fixed version for your release line: 2.0.9, 2.2.4 or 2.3.1.
Is CVE-2026-46680 being exploited?
There is no known exploitation of CVE-2026-46680 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Other vulnerabilities in containerd
- CVE-2026-53488 containerd CRI — image-config `LABEL` flows to restart-monitor `binary://` logger: host-root command execution from an image pull
- CVE-2026-53492 containerd CRI checkpoint restore CDI annotation smuggling
- CVE-2026-53489 containerd: Arbitrary host CRI log file read via symlink following in CRI checkpoint restore
- CVE-2025-47290 Containerd vulnerable to host filesystem access during image unpack
- CVE-2024-25621 containerd affected by a local privilege escalation via wide permissions on CRI directory
Sources
Also known as AZL-91668, BELL-CVE-2026-46680, CLEANSTART-2026-GA19307, CLEANSTART-2026-XP05903, CLEANSTART-2026-ZM97494, DEBIAN-CVE-2026-46680 and 167 more.